Support » Plugin: Custom Post Type UI » Custom Post Type UI and categories and tags not working

Viewing 9 replies - 1 through 9 (of 9 total)
  • MichaelH

    (@michaelh)

    That’s not the plugin causing that, that’s the way WordPress works right now.

    Hopefully that kind of thing will get resolved in the future.

    You might create a ticket in trac for that.

    bunnykins

    (@bunnykins)

    I never can find any thing useful in the codex just a lot of writing and nothing that answers the question of why I was looking at it.
    So how do you create a ticket in the trac?

    bunnykins

    (@bunnykins)

    scribu

    (@scribu)

    To make category archives display all posts, regardless of post type, add this piece of code in your theme’s functions.php:

    function any_ptype_on_cat($request) {
    	if ( isset($request['category_name']) )
    		$request['post_type'] = 'any';
    
    	return $request;
    }
    add_filter('request', 'any_ptype_on_cat');
    bunnykins

    (@bunnykins)

    Yay that worked so is that going to be added to 3.1?

    Ian

    (@ianaleksander)

    This seems to work, but at the top of the page on paginated category listings, it often says “Nothing found for” as if it was only reading the posts in there and once it gets to the end of the post count (not counting custom types) it titles the page as if there are no posts.

    any fix for this?

    AHHH scribu thank you!!!!

    Scribu, you’re the bomb.com, thanks!

    @scribu Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Custom Post Type UI and categories and tags not working’ is closed to new replies.