Support » Plugin: Frontier Post » Custom Post Type Permissions

  • Resolved ricks03

    (@ricks03)


    I have a custom post type: tripreport

    In FP I have configured
    Settings>Allowed Post Types: post, page, tripreport

    I then have a page with the shortcode:
    [frontier-post frontier_add_post_type=”tripreport”]

    When I attempt to load the page, I get an error:

    You are not allowed to add new post type: ”tripreport” – Allowed: (post, page, tripreport)
    Post type does not exists: ”tripreport”

    I clearly have a post type “tripreport”, both because I created it, and because FP sees it as an allowed post type!

    So why is it reporting an error that the tripreport post type does not exist?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter ricks03

    (@ricks03)

    If I make the shortcode:
    [frontier-post]

    the page loads.

    Thread Starter ricks03

    (@ricks03)

    Following the suggestion from a report several years ago,
    [frontier-post frontier_add_post_type=tripreport]

    seems to resolve the issue. It’s a bug, but at least I can work around it now!

    (Great plugin, clearly built by someone who understands the need to be able to customize and extend things!)

    Plugin Author finnj

    (@finnj)

    I have seen some issues with double quotes in the shortcode, can you try and retype it in manually. If pasted it sometimes goes wrong, do not know why

    also is the post type public ? (‘public’ => true)

    I will have a look at it on next release

    Plugin Author finnj

    (@finnj)

    have you enabled cashing (FP advanced setting) ?

    and can you post the tripreport definition code here?

    Thread Starter ricks03

    (@ricks03)

    I do know why copy/paste does’t work I think! The code that is copy/paste from the site is using “smart quotes” instead of well, not smart quotes. I had a number of other weird problems in other shortcode things that were fixed from that (just deleting the smart quotes, and re-entering them as normal quotes).

    So this is now resolved.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Custom Post Type Permissions’ is closed to new replies.