WordPress.org

Support

Support » Multisite » [Resolved] Custom post type keeps logging me out

[Resolved] Custom post type keeps logging me out

  • A bit of background first:
    I’m using an add-on domain (banhuarevolver.com) so the root of the site is a level deeper (primary domain is thecageclub.com). Tech support gave me some code for the .htaccess so that the wildcard would point subdomains to the right spot:

    # Skip rewrite if subdomain is www (we already know where www.addondomain.com is hosted, thanks to apache)
    RewriteCond %{HTTP_HOST} !^www\. [NC]
    # Extract (required) subdomain to %1
    RewriteCond %{HTTP_HOST} ^([^.]+)\.banhuarevolver\.com(:80)?$
    # Rewrite to /banhuarevolver/URL-path
    RewriteRule (.*) /banhuarevolver/$1 [L]

    And everything works fine with that .htaccess in my public_html folder and another .htacces file (with the that WordPress generated) in my banhuarevolver folder (where the multisite is installed)

    Now I’ve installed a plugin called Webcomic, which adds a custom post type (for uploading comics) but whenever I go to make a new such post, I get logged out.
    Now I’m not sure if this is an issue with the .htaccess, or subdomains or custom post types or the whole plugin. So any possible insight would be great.

Viewing 1 replies (of 1 total)
  • Turns out a piece of javascript in the plugin was causing the logout. No idea why (it just ads a dynamic dropdown menu) but removed it.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Custom post type keeps logging me out’ is closed to new replies.
Skip to toolbar