Support » Fixing WordPress » Custom post type in wp-admin no longer shows custom fields as a screen option

  • I updated to WordPress 4.8.1 today. Everything is working well except when I go to my custom post type that I have registered via a custom plugin when I go to edit a post in that section I am no longer able to display “custom fields”. There is supposed to be a checkbox under Screen Options but all I see are Featured Image, Yoast SEO, DAV Featured Group, and Slug. I have layout options for 1 column, 2 column, and enable full height editor.

    I checked my plugin and I have “custom-fields” set in the supports section.

    We’ve had this plugin running for a long time. Over the last few months, I have been working on a new version of the plugin. Throughout development I had always seen the custom fields as the plugin relies on them to work. Was there a change to this in v4.8.1 because to have disappeared today after I updated WordPress.

Viewing 1 replies (of 1 total)
  • I have tried on a development site switching to the default WordPress 2017 theme. When I do that I can go to the Edit Posts screen and see the Custom Fields option in the screen options menu along with all of the other options that should be there.

    I’m looking through the 2017 Theme and i am not seeing anything special in there that would enable the custom fields option.

    I also don’t see anything in my plugin or theme that should remove these options.

    This issue came up after I updated to WP 4.8.1. Is there a new to show/hide the custom fields?

    And just so show some more details, both my custom post type and the standard posts section do not show “custom fields” as an option under “Screen Options”. In fact they only show three things under Boxes. “Featured Image, DAV Featured Group, and Slug”.

    In my plugin, this is what I have — it is wrapped in a class:

    add_action('init', array($this, 'setup_post_type'));
    
    // Setup the custom post type for the videos
        public function setup_post_type() {
            add_theme_support('post-thumbnails');
            register_post_type('thankavet', array(
                'labels' => array(
                    'name' => __('Thanks Videos'),
                    'singular_name' => __('Thanks Video')
                ),
                'public' => true,
                'supports' => array('title', 'editor', 'custom-fields', 'thumbnail'),
                'has_archive' => true,
                'menu_icon' => 'dashicons-format-video',
                'rewrite' => array(
                    'slug' => 'thank-you'
                )
              )
            );
          }

    I am still digging, but if someone knows what happened with 4.8.1 related to that screen options menu, i’d be greatful if someone offered some assistance here. I just want to get the custom fields to appear in the Edit Post page.

    • This reply was modified 2 years, 6 months ago by robbiegod.
Viewing 1 replies (of 1 total)
  • The topic ‘Custom post type in wp-admin no longer shows custom fields as a screen option’ is closed to new replies.