Support » Plugin: Custom Post Type UI » Custom Post Type categories gives 404 error

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    The first two URLs are leading to 404 pages, for what it’s worth.

    I think these are the intended urls:

    http://www.doughmain.com/pub/entertainment/
    http://www.doughmain.com/pub/entertainment/african-entertainment/

    My initial hunch is stemming from the fact that both are named “entertainment” in slug with no rewrite slugs provided nor alternate query_var values. I have to believe that WordPress isn’t sure what it should be querying for, or is trying to query for a post type post named “african-entertainment” when you’re meaning for it to be taxonomy term archive.

    What happens when you rename one of them to a different slug, and migrate any existing content with that.

    Hi Michael,

    Sorry for the confusion — the “ourdomain” part was just as example. the site is still hosted within our local dev. environment.

    I have now renamed the Taxonomy to “entertainers” & ticked “Migrate terms to newly renamed taxonomy?”

    I am still getting a 404 error…

    Kind regards
    Francois

    Sorry Michael, I think that suggestion of your did the trick. I had to quickly recreate the menus as well and it seems to be working now 🙂

    Thanks for your quick reply on this!!

    Kind regards
    Francois

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    ah, I didn’t see the “our domain” aspect, and my urls are actually different than what you provided originally 😀

    Awesome to hear that the rename and some quick menu fixes seems to have done the trick. Glad it was simple-ish like that.

    Let us know if you encounter any other curiosities.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Custom Post Type categories gives 404 error’ is closed to new replies.