Support » Plugin: Translate WordPress with GTranslate » Custom post type

  • Resolved datavalue

    (@datavalue)


    Hi,

    The plugin does not seem to translate Custom Posts Types.
    At this time, I try the free version.

    Thank you very much for your help.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author edo888

    (@edo888)

    Hi,

    I have just checked your website and I see that everything is translated. May be you can point out where exactly I should look?

    You may also contact our live chat and describe the issue more in details: https://gtranslate.io/#contact

    We do not have issues with translating custom post types.

    Thanks! πŸ™‚

    Hi,

    Sometimes CPT are translated, sometimes not…
    I give you an example:
    – I switch to English language on the homepage (https://www.datavalue.fr) -> translated
    – In the Statistical menu, I choose “Basics of Statistics” (https://www.datavalue.fr/formation-bases-statistique/) -> translated
    – I follow the link “Descriptive statistics (exploratory): knowing how to describe observations” (https://www.datavalue.fr/formation-statistique-descriptive-exploratoire) -> not translated the first time but can be translated after visiting another page… or not!
    The problem appears only with CPT, never with posts or pages.

    Thank you for your assistance.

    Plugin Author edo888

    (@edo888)

    Hi,

    Can you disable Autoptimize cache plugin and try again?

    Thanks! πŸ™‚

    pro-tip; you can disable Autoptimize on a per-request basis by adding ?ao_noptimize=1 to the URL.

    if the problem is not there at that point, some autoptimize (re-)configuration might be needed to fix this. there are troubleshooting tips and info on how to exclude in the AO FAQ.

    hope this helps debugging,
    frank (ao dev)

    Plugin Author edo888

    (@edo888)

    Hi Frank @optimizingmatters,

    Thanks for your input. Unfortunately to replicate the issue we have to follow some links and ?ao_noptimize=1 doesn’t help here, because it does not append that parameter in internal links of a page.

    Hi,

    You’re right, your plugin seems to be not compatible with autoptimize.
    It will be hard if I have to make a choice!

    Thanks,

    CΓ©dric

    Well, taking a step back; try to identify what is breaking things by just disabling CSS or JS or HTML or Image optimization (incl. lazyload)? Based on that we can see what the next steps are to have the 2 plugin co-exist πŸ˜‰

    frank

    Plugin Author edo888

    (@edo888)

    Thanks Frank for taking care. I was about to suggest the same πŸ™‚

    Hi Frank,

    Thanks for your help.
    Disabling JS in autoptimize solves the problem.
    So I tried to use the option “Exclude scripts from Autoptimize” adding entries https://translate.googleapis.com/* and https://translate.google.com/*
    Unfortunately, without any success …

    Can you try adding plugins/gtranslate/ to the comma-separated JS opt. exclusion list?

    The problem still persists…

    OK, taking a step back:

    1. can you try excluding each of the below one by one to see which one fixes things?
    * wp-content/plugins/
    * wp-content/themes/
    * wp-includes/js

    2. can you try if unticking “aggregate JS” helps?

    Thanks.
    Unticking “aggegate inline js” solves the problem but breaks a jQuery ready function.

    in that case you’ll have to (re-)exclude js/jquery/jquery.js from JS optimiztion :-/

    All works like a charm.
    Thank you very much for your awesome support.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.