Support » Plugin: AMP for WP - Accelerated Mobile Pages » Custom Post Tye extension not working

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor ampforwp

    (@ampforwp)

    Hi @utnalove,

    Thank you for bringing this to us.

    I’ll definitely do my best to solve your queries and give you all the information. So, let us begin 🙂

    A1) The reason for using the Custom Post type is generally we use Posts and pages. However, if you want to build and output the content other than posts/pages, you can also use Custom Post types and select it from the General settings of AMP Option Panel, only then it’ll work.

    A2) Simply enabling the Custom Post type extension will not give us the output, instead we need to select the custom post types made by us from the general settings which will then output your Content.

    A3) I’, sorry but I have not checked https://www.masaztantrycznywarszawa.pl/nasze-masaze/amp/ site so I cannot give you the proper update on this if I check this how they’re outputting the values I can definitely let you know about it.

    A4) https://prnt.sc/loucwh This part is known as a Custom Post Template through which the output isn’t rendered in AMP, you need to add the data in the ” the content ” area so that to be displayed in the AMP Version, this is how it works in AMP.

    Just do let me know if you’ve any further queries I’m here to help you out with all of them.

    Thread Starter utnalove

    (@utnalove)

    Hello, that’s very sad, because nowadays about 99% of the themes that are being sold on Themesforest, templatemonster, etc do have such “Custom Post Template”.

    A very expensive Plugin like AMP for WP is not supporting such basic feature.

    I bought it because it said it supports custom post types.

    In order to show custom post types in wordpress pages, a special “Custom Post Template” has to be selected. This is how most themes work.

    Probably it’s just few lines of code to be added. Can you please help to support it?

    Plugin Contributor ampforwp

    (@ampforwp)

    Hi @utnalove,

    I agree with your point and thank you for providing the information to me.

    I will definitely help you with this, I need to discuss with my internal team and once I’m done with it I’ll give you an update on it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Custom Post Tye extension not working’ is closed to new replies.