Support » Plugin: Kocuj Sitemap » Custom post

  • Resolved marcusrossi

    (@marcusrossi)


    Hi!

    When I activate the custom post “recipes” I get this:

    Fatal error: Class ‘KocujSitemapPlugin\Classes\Url’ not found in /home/veganfoo/public_html/wp-content/plugins/kocuj-sitemap/classes/element-type/backend/custom.class.php on line 149

    Why is that?

    https://wordpress.org/plugins/kocuj-sitemap/

Viewing 6 replies - 1 through 6 (of 6 total)
  • marcusrossi

    (@marcusrossi)

    Also, I am using qtranslateX + Integration: Yoast SEO & qTranslate-X, qTranslate slug, qText X Widget

    Plugin Author Dominik Kocuj

    (@domko)

    Hi.

    I’ve just looked into my plugin code and it is bug. I’ve changed some time ago some classes names and in this line I’ve not changed it (it use old class name). Somehow it was not visible during tests. I’m very sorry for this bug, because it was something which can be easily avoided.

    Today I will release a fixed version. I’ll let you know when it will happen.

    Plugin Author Dominik Kocuj

    (@domko)

    Version 2.2.3 has been released. It fixes this bug.

    Please, let me know if it works for you.

    marcusrossi

    (@marcusrossi)

    Hey Dominik, it worked! Thanks for fixing it 🙂

    But how to I separate the posts and the categories? On recipes the ingredients are mixed with the recipes and the difficulty level. I tried using the options but it doesn’t separate them. Is this something with my theme?

    https://veganfoodandfriends.com/sitemap/

    Plugin Author Dominik Kocuj

    (@domko)

    No problem 🙂 I’m glad it works.

    Yes, it looks like your theme has no styles for multi-level list. It is not rare problem – I had some information about this on other websites too.

    I recommend to write to theme author with information about this bug, because you will have this problem in other places on your website if you will use a multi-level list in some article (for example, post).

    However, I have the solution which will fix problems with the sitemap right now. The Kocuj Sitemap plugin has option for this which will add some indentation to posts in the sitemap. Please, see FAQ (https://wordpress.org/plugins/kocuj-sitemap/faq/) – question: “My multi-level sitemap has no indentations. What should I do?”. This should help.

    marcusrossi

    (@marcusrossi)

    Ok thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Custom post’ is closed to new replies.