WordPress HTTPS (SSL)
Custom port doesn't work on CSS and JS files (2 posts)

  1. mzient
    Posted 3 years ago #


    I have a webpage secured on custom port :2443.
    After enabling the plugin (option 'Force SSL Administration' checked), the main HTML request works properly on port :2443, but CSS and JS are requested on default :443.

    It is how it looks in Firebug:
    https://domain.com:2443/wp-admin (ok)
    https://domain.com/wp-admin/css/wp-admin.css?ver=3.4.2 (not loaded)

    Are there any settings i need to apply?

    Any help would be greatly appreciated


  2. mzient
    Posted 3 years ago #

    if you want to use other port than 443, read this what i hope save you some time.

    - i realized that, for some reasons plugin didnt want to save my port settings to database
    - i manually changed in table wp_options field named 'wordpress-https_ssl_port' to '2443' (my custom port) - it didnt really help, but
    - i manually changed in table wp_options field named 'wordpress-https_ssl_host' from 'https://domain.com/' to 'https://domain.com:2443/' - and that worked

    I didnt have enough time to analyse why these settings work, the plugins author would know best, but it works properly without any problems.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic