WordPress.org

Support

Support » How-To and Troubleshooting » Custom Permalinks

Custom Permalinks

  • I’m having sever issues with customizing my permalink structure.

    I’ve chosen /%year%/%monthnum%/%day%/%postname%/ as the structure, and I’ve set the permissions on the .htaccess file to 666. What happens is that the permalink structure is created (hover over a post title), but when you click on a post, it simply takes you back to the home page.

    The website is : http://www.conflictoflaws.net

    Any help at all would be greatly appreciated. I’ve been through codex.wordpress.org/Using_Permalinks to no effect.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I had that problem on my old host, and solved it by using Ryan Boren’s little plugin: http://boren.nu/downloads/rewrite.phps
    (paste it into a file and name it something handy like rewrite.php)

    You are a truly wonderful person (in guess you hadn’t guessed by that unnecessarily extravagant compliment, it now works!)

    Are there any disadvantages nowadays with using /%postname%/ only?

    Many thanks.

    Just happened to be at the right time at the right moment… 🙂

    According to the codex there can be some complications with using postname only: http://codex.wordpress.org/Using_Permalinks#Structure_Tags
    If you try it anyway and problems occur, my guess is that they are easily fixed by deleting the .htaccess, but don’t quote me on that one.

    I am having problems with my custom permalinks aswell. This happened after my webhost had a hardware failure and my blog was down for merely a day.

    Only default permalinks are working now.
    My custom permalinks looks like this:
    %year%/%monthnum%/%postname%/

    http://www.krugern.no/

    when using my custom permalinks all links take me back to my frontpage.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Custom Permalinks’ is closed to new replies.
Skip to toolbar