Support » Plugin: Custom Permalinks » Custom Permalinks stopped working after upgrade to WP 3.9.1 leading to 404 error

  • V

    (@vitaliss)



    Now leads to 404 errors on all pages 🙁

    My default permalinks are not the default “?p=123″ style.

    My URL rewriting enabled. Just in case I tried deleting .htaccess and replacing it with recommended:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    This doesn’t solve the problem at all.

    *Please* help! 🙂

    https://wordpress.org/plugins/custom-permalinks/

Viewing 10 replies - 1 through 10 (of 10 total)
  • yes, my wordpress site also like that…..

    WordPress 3.9.1 have permalink bug

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    WordPress 3.9.1 have permalink bug

    No, it doesn’t. Have you both tried resetting your permalinks?

    Yeah, after 4 hour analyze and trying….with Centos 6
    the problem is on default configuration http.cnf…

    AllowOverride None
    Change all of this line to:
    AllowOverride All

    and it’s works Greats,,

    but I still d’nt understand why the problem is on default httpd.cnf

    where the settings have been applied in a virtual host conf

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    AllowOverride None
    Change all of this line to:
    AllowOverride All

    and it’s works Greats,,

    Yes and that’s how it’s supposed to be. The AllowOverride None will limit the mod_rewrite from doing it’s job. You need that All to make sure it works.

    There may be a way to do it without All but I’ve never tried and use the same config line as you did.

    Hi – I have the same issue as above, please let me know where do i find the above file to edit the code? Many Thanks

    Hi there,

    The solution described above is not a very safe one, and it doesn’t solve the problem. The real issue is WordPress changed the way the database has to be addressed since version 3.9, and the plugin hasn’t adapted tot this yet. You can download a fixed version here: http://www.sowmedia.nl/custom-permalinks-0.7.19.zip

    I’ll try informing the author.

    Regards,
    Sowmedia.nl

    Plugin Contributor michaeltyson

    (@michaeltyson)

    Many thanks, @sowmedia! New version (0.7.19) has been released.

    How do I upload the permalinks fix? I am having the same problem. Has there been an addition fix since this post? thanks

    I’m using WordPress 3.9.3 and facing the same problem.

    I copied the htaccess setting below..

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    and what I got is the link redirect to localhost/xampp

    Is there something wrong?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Custom Permalinks stopped working after upgrade to WP 3.9.1 leading to 404 error’ is closed to new replies.