Support » Fixing WordPress » Custom permalinks not working after upgrading wordpress

  • Keshav Saini

    (@environmentabout)


    I have been trying to upgrade to wordpress version 3.1.2 but after the upgrade, my custom permalinks are not working. All my post links are showing up 404 not found page. When I switch to default perlink setting, it works.

    Not only it is happening with WP 3.1.2 but the same thing is happening with WP 3.0.6 also.

    More Details:
    I have been upgrading manually using FTP.

    I have performed every trick/hack that is available on net e.g disabling plugins, rewritting .htaccess file etc…

    I am using (postID/post name) permalink structure..

    I again have to go back to my previous version due to permalinks not functioning. My theme is comapatible with WP 3.0

    My blog URL is http://www.environmentabout.com/

    Problem: The main page or home page is working fine at above URL. But when I visit my post pages with custom permalink structure (http://www.environmentabout.com/928/global-warming-how-rapidly-will-sea-level-rise) they return 404 page not found error. But it works with default permalink structure(http://www.environmentabout.com/?p=928).

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator t-p

    (@t-p)

    Have you tried resetting your custom permalinks back to the default setting and renaming your WordPress .htaccess file. If that works, then try reading Using_Permalinks before setting a custom permalink structure again. Documentation: http://codex.wordpress.org/Using_Permalinks

    Keshav Saini

    (@environmentabout)

    I did that but didn’t try renaming the htaccess file. What should I rename it to?? Something before dot or after dot??

    I even restored my previous htaccess file but the problem remains the same.

    Moderator t-p

    (@t-p)

    something like .htaccessHOLD

    the trick doesn’t work. Environmentalbout how did u fix it at the end? I checked ur site, it’s working right?

    thanks

    Keshav Saini

    (@environmentabout)

    The problem was with my localhost installation and not with live site. The apache module rewrite module was not activated in wamp server.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Custom permalinks not working after upgrading wordpress’ is closed to new replies.