WordPress.org

Support

Support » Plugins and Hacks » Custom Permalinks » Custom Permalinks Not Updating WooCommerce Product Category Permalinks

Custom Permalinks Not Updating WooCommerce Product Category Permalinks

  • Hello,

    I saw that there was a post about this issue before, but it was not resolved before being closed.

    The problem I am having is that the Custom Permalinks plugin does not save my changes when trying to set a Custom Permalink for a Product Category in WooCommerce.

    To replicate the issue – Install WooCommerce and Custom Permalinks plugins on a site, go to Products > Categories, create a category, and click to edit that category. Once you are in the editor for the category you will see a field labeled “Custom Permalink”. If you enter a value in that field to set the permalink for that specific category and click Update, the value is not saved and the custom permalink you were trying to create does not work.

    The Custom Permalink plugin works great for Posts, Pages, Post Categories, Products, etc. The issue is with WooCommerce Product Categories ONLY.

    Any help on this is greatly appreciated!

    https://wordpress.org/plugins/custom-permalinks/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Using WordPress 3.9.1 and WooCommerce 2.1.11.
    I am having a similar issue and could not find any recent solutions. When I try to use custom permalinks for my shop/products, and you click on a product, I get page not found error (it should open a new page with product details). When i set my permalinks to the default settings, the catalog/product pages work perfectly, but my site URLs have the crappy permalink [hxxp://mysite.com/?p=123] which looks horrible and is even worse for SEO.

    Would love a fix on this! Thanks!

    This is because the custom permalinks are not working (yet) on custom taxonomy’s. I was trying to use it with custom taxonomy’s as well, and it just keeps resetting.

    I am having the same problem, has anyone figured out a fix to this issue, even if you are using another option?

    aspa_kat

    @aspa_kat

    any solution?

    I came here in search of a solution to this. This plugin would be spectacular (I would even pay for it) if it could handle custom taxonomies ESPECIALLY for WooCommerce Product Categories.

    Had great plans, then it didn’t work with product categories 😛
    I’m experiencing the same problem.

    +1 for an answer!

    Also for product attributes

    Hey guys,

    This isn’t the best solution and I’m sure it won’t work for everyone. I basically just created WP pages, set the custom permalink the way I needed it (thanks to the Custom Permalinks plugin), and used short codes to display the products.

    [product_category category=”somecategory”]

    I also set the custom permalink of each individual product.

    Again, it’s definitely not an ideal solution. Still hoping someone will come along with a better answer.

    Hello,

    I need on my eShop(woocommerce) some empty categories to be redirected to special page. Since i figured, that custom permalinks wont work, i have no idea how to do that. Any solution how to asign some category custom link?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Custom Permalinks Not Updating WooCommerce Product Category Permalinks’ is closed to new replies.
Skip to toolbar