Support » Plugin: All in One SEO Pack » Custom page titles not being displayed correctly

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author wpsmort

    (@wpsmort)

    Support Manager at Semper Fi

    Hi swearingdad,

    Do you have an example of a page where this is happening? Can you provide the URL to the page along with the custom title you have set for that page.

    swearingdad

    (@swearingdad)

    Hello – how we start with my site http://www.swearingdad.com

    I have these settings in the plugin for the home page:

    Home Title:
    SwearingDad – Simon Watson, Effective Design for Web & Print

    Home Description:
    SwearingDad Design delivers effective and creative graphic design and artwork for logos, identity, websites, e-commerce and print. Based in Maidenhead, Berkshire, UK.

    Home Keywords (comma separated):
    simon watson, swearingdad, graphic designer, identity, website, print, logo, freelance, effective, creative, practical, design, artwork, maidenhead, berkshire, united kingdom

    However I am wondering if it is a theme issue?

    Thanks

    Simon

    Plugin Author wpsmort

    (@wpsmort)

    Support Manager at Semper Fi

    Hi Simon,

    The answer is yes, All in One SEO Pack is having an issue writing the title to the source code, probably because of your theme. Try changing the following settings to see if this fixes the issue:

    All in One SEO, General Settings, Use Original Title (http://semperplugins.com/documentation/general-settings/#use-original-title)
    All in One SEO, Performance, Force Rewrites (http://semperplugins.com/documentation/performance-settings/#forcerewrites)

    swearingdad

    (@swearingdad)

    Hi, thanks for the quick response, I tried both these but neither worked.

    I have contacted the theme authors (themify.me) and they suggested the following (which I have not tried yet – I will do so as soon as I can as I need to create a child theme first) so I don’t know if this helps you:

    ——-

    This seems like a bug in the All in one SEO plugin, it’s unable to locate the title tag in the theme. As a workaround you can first create a child theme (http://themify.me/docs/child-themes) and copy header.php file to <child-theme>/header.php and open it up, now find:

    <title itemprop="name"><?php wp_title( '' ); ?></title>

    And replace that with:

    <title><?php wp_title( '' ); ?></title>

    Plugin Author wpsmort

    (@wpsmort)

    Support Manager at Semper Fi

    Hi Simon,

    Let me know if their suggestion works and we may need to change our code to recognize the first line of code they provided. Normally the title line in the header.php file would look like the second line of code they provided.

    swearingdad

    (@swearingdad)

    Hello

    Their PHP editing suggestion does work. I have updated http://www.swearingdad.com and all is now well.

    So is this something you need to alter on the plugin? Or is it a theme issue?

    Thanks for all your help so far.

    Simon

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Custom page titles not being displayed correctly’ is closed to new replies.