WordPress.org

Support

Support » Multisite » Custom metas don't work in multi-site

Custom metas don't work in multi-site

  • I have a really interesting problem that I have no clue how to fix, and Google is turning up nothing.

    In a 3.0 multi-site set up, I have created a custom post type and added custom meta boxes to it. The custom post type works fine, but the meta boxes, nor the custom taxonomy I created for the post type, show up. Nor do they throw any errors.

    However, running the exact same set up on a non-multi-site 3.0 install works perfect.

    Any clues to why custom metas / taxonomies don’t work with multi-site?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Did you add the code to the theme’s functions.php file, or did you toss it in mu-plugins?

    in my own tests custom posts types *do* work in multiple sites. Just not *across* multiple sites.

    The custom post types are being registered by a plugin in the wp-content/plugins folder.

    I’ve done some more testing and have so far been unsuccessful. I tried writing an entirely new custom post type function . . . no luck. I tried throwing it in mu-plugins . . . no luck.

    In every case though, the custom metas work perfect on non multisite installs.

    I have the same problem… custom taxonomies do not show up in after multi site is installed.

    Did anyone has success in achieving this?
    I’m trying a simliar thing.
    The taxonomies appear in all sites, but the custom content type only appears if the user is a side-wide administrator.
    No good solution 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Custom metas don't work in multi-site’ is closed to new replies.