WordPress.org

Support

Support » How-To and Troubleshooting » Custom Menu problem in IE7

Custom Menu problem in IE7

  • I absolutely love the new Custom Menu feature. However, IE7 can’t seem to process them.

    In Firefox 3.5 and Chrome, the menus appear as boxes stacked horizontally which change color on hover. In IE7, only the first unit–home–appears. The first unit changes color, so I know it’s calling the right CSS sheet, but after that, the page goes to hell. The rest of the menu is not present. Text further down the page is present, but the formatting is off (wrong background colors, etc). The best I can guess is that the at the end of the home entry is gumming up the works but I can’t explain why. Any guesses?

    Here is my code:

    <tr><td>
    <?php wp_nav_menu( array (‘menu_id’ => ‘topmenu’)); ?>
    </td></tr>

    The CSS:

    #topmenu {
    float: center;
    list-style: none;
    align: center;
    padding:0;
    height:10px;
    font-size: 15px;
    background:#111146;
    }
    #topmenu li {
    width:100%;
    align: center;
    background: #111146;
    margin-left: auto;
    margin-right: auto;
    margin-top: 0;
    padding: 0;
    }
    #topmenu a {
    background: #111146;
    color: #ffffff;
    display: block;
    float: left;
    padding: 4px 12px;
    text-decoration: none;
    /* font-weight:bold;*/
    border-color:#111146;
    }
    #topmenu a:hover {
    background: #24248e;
    color:#ffffff;
    padding-bottom: 4px;
    font-style:bold;
    }

    THANK YOU!!!

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Custom Menu problem in IE7’ is closed to new replies.
Skip to toolbar