Support » Plugin: AMP » Custom JavaScript is not allowed. suddenly getting this in Google search console

  • Resolved m3gadeath


    We run Newspaper theme with AMP Plugin and after latest update we are getting Custom JavaScript is not allowed. and all are amp pages are showing this error in Google webmaster tools. Can someone help how to resolve this.

    When inspected URL this is what the console shows-

    1) <script>’undefined’=== typeof _trfq || (window._trfq = []);’undefined’=== typeof _trfd && (window._trfd=[]),_trfd.push({‘tccl.baseHost’:’’}),_trfd.push({‘ap’:’cpbh’},{‘server’:’sg3plvcpnl401584′}) // Monitoring performance to make your website faster. If you want to opt-out, please contact web hosting support.</script><script src=’’></script></html&gt;

    2) <script src=’’></script></html&gt;

    Any help will be good.
    [ redundant link removed ]

    • This topic was modified 1 year, 8 months ago by Yui.
    • This topic was modified 6 months, 1 week ago by Jan Dembowski.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support James Osborne


    From the error you reported there may be hosting related snippets inserted into your site, see this article.

    Can you confirm share your Site Health information using this form and be sure to confirm your hosting provider in the related field? I’ll try and reproduce the same validation error from my side.

    Thread Starter m3gadeath


    Hi, Thanks, Godaddy on their own put us on the RUM (Customer Experience Improvement Program) program, without informing us.
    We opted out of it and seems like the script has evaporated. The console is validating, will let you know if the error goes away completely. Thanks for the help.

    Plugin Author Weston Ruter


    I’ve reached out to GoDaddy to see if this can be automatically disabled on AMP pages.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Custom JavaScript is not allowed. suddenly getting this in Google search console’ is closed to new replies.