WordPress.org

Support

Support » Plugins and Hacks » Awesome Flickr Gallery » [Resolved] Custom Image size not functioning

[Resolved] Custom Image size not functioning

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Ronak Gandhi

    @ronakg

    Create a directory called “cache” inside the plugin directory and make sure the permissions for this cache directory is 777.

    bretjg

    @bretglassett

    Thanks, there are still issues I see:

    1. In the source code, the A tag is in the middle of the IMG tag:
    <img class="afg-img" src="http://stage.pactimo.com/wp-content/plugins/awesome-flickr-gallery-plugin/afg_img_rsz.php?src=http://farm9.static.flickr.com/8048/8138903607_416efc0d45_m.jpg&q=100&w=116&h=116" alt="2012 Boulder Cup CX • <a style=&quot;font-size:0.8em;&quot; href=&quot;http://www.flickr.com/photos/33527461@N03/8138903607/&quot; target=&quot;_blank&quot;>View on Flickr</a>">

    2. The image src produces an error when accessing it directly, .e.g http://stage.pactimo.com/wp-content/plugins/awesome-flickr-gallery-plugin/afg_img_rsz.php?src=http://farm9.static.flickr.com/8048/8138903607_416efc0d45_m.jpg&q=100&w=116&h=116 produces the error:

    A TimThumb error has occured

    The following error(s) occured:
    An error occured fetching image.

    Query String : src=http://farm9.static.flickr.com/8048/8138903607_416efc0d45_m.jpg&q=100&w=116&h=116
    TimThumb version : 2.8.5

    markpea

    @markpea

    “Create a directory called “cache” inside the plugin directory and make sure the permissions for this cache directory is 777. “

    There is a directory called cache inside awesome-flickr-gallery-plugin but it inherits it’s permissions from when it was created and so may not be writable by the apache user (mine was not). I changed permissions with chmod 775 cache and that fixed the problem I was having (basically the message mkdir(): File exists appeared on every page). Would you add a note to the installation instructions suggesting to check that the cache directory is writable by the owner of the http process (ie www / nobody) — so permissions may be 775 or 777?
    Thanks

    bretjg

    @bretglassett

    markpea – are you using custom image sizes?

    I’ve been having this problem with custom image sizes for a month or two now. Initially blamed the hosting provider as nothing had changed (as far as I knew) with my site.

    However, I’ve now tested it with three different hosting platforms (running both PHP5.3 and 5.2) with a clean WP 3.5 install on each and only AFG 3.3.3 plugin activated. Two out of the three hosts failed to show the custom sized thumbnails I’d specified.

    Read on RonakG’s site a couple of threads where users had downgraded AFG to 3.2.4. I’ve now tried this and am happy to say all is now well with both of my websites and custom thumbnail sizes.

    I’ve made no changes to my hosts standard folder permissions (though haven’t checked what they are either).

    I can only conclude that with 3.2.4 working nicely, 3.3.x seems to have custom thumbnail sizing issues with certain hosting provider setups.

    Hope that helps folks who are trying to get this to work.

    M

    Plugin Author Ronak Gandhi

    @ronakg

    Can you folks update to latest version 3.3.6 and let me know if it is working or not?

    Oh WHY is TimThumb doing this to us!!!!! This latest script sucks!!!!!

    Also, my flicker gallery still does not show thumbnails with the custom size setting on version 3.3.6 either.

    Plugin Author Ronak Gandhi

    @ronakg

    Make sure there is a cache directory inside AFG plugin directory and cache directory’s permissions are set to 777.

    Yes, I have the cache directory set to 777. Still isn’t working.

    I haven’t fooled around with this recently but if my experience with other plugins using Flash to do things is anything to go by, the regular updates from Adobe have killed certain aspects of plugin functionality.
    I’m going to test this theory in a PC Lab that has an older version of Flash installed into Firefox. Will get back.

    I have 3.3.6 as well, but the thumbnails do not correctly show when selecting custom width.

    I guess where would we go to change the default size option? Since its already set to 75px (Square) How would I change the 75px, to say 150px?

    I changed lines in the index.php file that referenced the photo size as width=75, to width=150, however I did not see any change…

    Sorry, Not sure why this is marked as resolved…lol what is the solution?

    Yeah… there is no solution yet.

    Oh, Ok I thought I missed it.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Resolved] Custom Image size not functioning’ is closed to new replies.
Skip to toolbar