Support » Plugin: Social Share Icons & Social Share Buttons » custom icons image addresses have made website state unsecured

  • Resolved mohammad177

    (@mohammad177)



    I have to custom icons (for Telegram and Aparat).

    I made my website secured with SSL yesterday.

    But custom icons still have made my website unsecured. You can check my website address (https://kafshvakif.com) with https://www.whynopadlock.com to know why.

    The problem is that your plugin uses HTTP address for custom icons image when we add a custom icon. This leads our website unsecured when we use HTTPS. When our sites are HTTPS, the plugin should put HTTPS at the beginning of the picture addresses for custom icons.

    I removed the custom icons once to test the website and it became secured. Now I added the customs again and the problem still remains.

    Please help me with a solution.

    Thanks

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author socialdude

    (@socialdude)

    Thanks for reporting this, we’ll check with the developers and get back to you.

    Plugin Author socialdude

    (@socialdude)

    Could you please confirm: Did you upload the custom icons again after the site switched to https?

    If you upload any other pictures in your media library – are those saved on http or https urls?

    mohammad177

    (@mohammad177)

    Thank you for paying attention to your plugin’s users.

    After I switched to HTTPS and realized there is a problem and the problem was because of custom icons URLs, I removed the custom icons from the plugin’s page and I removed the picture of them from the media library too. Then I added them again (after I switched to HTTPS) via plugin’s page but the problem still present.

    I uploaded a new image and I saw that it saved via HTTP. Then I went to the WordPress general settings and I saw that the WordPress URL is HTTP for my website. I changed it to HTTPS. Now my website URL is HTTPS in WordPress general settings. Then I decided to repeat the process of adding custom icons again from first. Now, The problem resolved and my website is secured now.

    Thanks again for your helpful support.

    Plugin Author socialdude

    (@socialdude)

    Cool, thank you for posting the solution here!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.