Support » Themes and Templates » Custom header link not working

  • I have made a custom header for my WordPress blog. I noticed that now you can’t click on the header at all (it usually takes you to the main blog page).

    However, I also can’t title the blog because of the header. If I enter a title for the blog, it adds the title over the top of the existing header.

    Any suggestions on how to fix this? Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • do you mind giving us the link to your page, or giving us the code that’s in the file labeled “header.php”/

    Sure, it’s http://www.carlabray.com/blog

    Here’s the header code:

    <!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Transitional//EN” “http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd”>
    <html xmlns=”http://www.w3.org/1999/xhtml” <?php language_attributes(); ?>>

    <head profile=”http://gmpg.org/xfn/11″>
    <meta http-equiv=”Content-Type” content=”<?php bloginfo(‘html_type’); ?>; charset=<?php bloginfo(‘charset’); ?>” />

    <title><?php bloginfo(‘name’); ?> <?php if ( is_single() ) { ?> » Blog Archive <?php } ?> <?php wp_title(); ?></title>

    <meta name=”generator” content=”WordPress <?php bloginfo(‘version’); ?>” /> <!– leave this for stats –>

    <link rel=”stylesheet” href=”<?php bloginfo(‘stylesheet_url’); ?>” type=”text/css” media=”screen” />
    <link rel=”alternate” type=”application/rss+xml” title=”<?php bloginfo(‘name’); ?> RSS Feed” href=”<?php bloginfo(‘rss2_url’); ?>” />
    <link rel=”pingback” href=”<?php bloginfo(‘pingback_url’); ?>” />

    <style type=”text/css” media=”screen”>

    <?php
    // Checks to see whether it needs a sidebar or not
    if ( !$withcomments && !is_single() ) {
    ?>
    #page { background: url(“<?php bloginfo(‘stylesheet_directory’); ?>/images/kubrickbg.jpg”) repeat-y top; border: none; }
    <?php } else { // No sidebar ?>
    #page { background: url(“<?php bloginfo(‘stylesheet_directory’); ?>/images/kubrickbgwide.jpg”) repeat-y top; border: none; }
    <?php } ?>

    </style>

    <?php wp_head(); ?>
    </head>
    <body>
    <div id=”page”>

    <div id=”header”>
    <div id=”headerimg”>
    <h1>/”><?php bloginfo(‘name’); ?></h1>
    <div class=”description”><?php bloginfo(‘description’); ?></div>
    </div>
    </div>
    <hr />

    why not make url("<?php bloginfo('stylesheet_directory'); ?>/images/kubrickbg.jpg") an image with a link attached on it.

    The biggest problem is that I can’t name my blog, so it comes up as “untitled” in blog directories.

    why not make url(“<?php bloginfo(‘stylesheet_directory’); ?>/images/kubrickbg.jpg”)

    Where does this go?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Custom header link not working’ is closed to new replies.