Viewing 15 replies - 1 through 15 (of 17 total)
  • Theme Author oceanwp

    (@oceanwp)

    Hello, you have created your custom header via Theme Panel > My Library, select Custom Header in the Style option via the Header > General of the customizer and selected your custom header in Select Template?

    Thread Starter vacances2000

    (@vacances2000)

    Hi,
    Yes I did… but doesnt work… It only works when I create the header as a normal WP page and when following your steps, select Page ID = Header instead of custom header in the next drop down

    Regards,

    Jonathan

    Theme Author oceanwp

    (@oceanwp)

    Don’t use the Page ID option because it will be deleted in a future release. All the plugins are up to date?
    Do you have any error when you select a template?
    What is your PHP version?

    Thread Starter vacances2000

    (@vacances2000)

    It was all installed today. Here are the versions:
    WP 4.8.1. ,
    cpsrvd 11.64.0.36
    Version du client de base de données : libmysql – 5.1.73
    Extension PHP : mysqliDocumentation curlDocumentation mbstringDocumentation
    Version de PHP : 5.6.30
    phpmyadmin: Version : 4.6.6
    Serveur : Localhost via UNIX socket
    Type de serveur : MariaDB
    Version du serveur : 10.1.24-MariaDB-cll-lve – MariaDB Server
    Version du protocole : 10

    I don’t get any error while proceeding. it just doesn’t display …

    Regards,

    Jon

    Theme Author oceanwp

    (@oceanwp)

    In your custom header, have you added any Elementor widgets?
    If no, try to add an Elementor widget to see if it work, if it does, add the Spacing widget with 0 margin and add the “no-margin” class to this widget.

    Thread Starter vacances2000

    (@vacances2000)

    Sure I added widgets such as the branding, default navmenu, social icons and search widgets plus a heading… So I tried adding the spacer widget, reduce space to minimum and in advanced CSS classes “no-margin”… No change unfortunately.. this has all been done in the header saved in the theme panel, not the elementor / my library

    Theme Author oceanwp

    (@oceanwp)

    You have done everything normally, I do not understand why this does not appear when you select your template created in Theme Paenl > My Library via the customizer.
    Do you use a child theme? If yes, activate the parent theme to see if the issue comes from the child theme.

    Thread Starter vacances2000

    (@vacances2000)

    Sorry, but how can I check it whether child or parent theme?

    Thx

    Theme Author oceanwp

    (@oceanwp)

    In your dashboard, Appearance > Themes

    Thread Starter vacances2000

    (@vacances2000)

    Parent theme. I never installed oceanwp-child-theme or similar …

    Theme Author oceanwp

    (@oceanwp)

    I just figured out why you have this problem 🙂
    Sorry I had not noticed before, you use the Elementor Canvas template, this template deletes the header and footer, so it’s normal that you do not see your header, you have to use the template by default and if you want a full width page, select the Full Width layout in OceanWP Settings.

    Thread Starter vacances2000

    (@vacances2000)

    When doing that (Theme panel > quick edit template from elementor to default), I get the default header on top of my customed header in the actual header template which is in the Theme panel library

    Theme Author oceanwp

    (@oceanwp)

    No, not in Theme Panel, in your page https://luxurybarcelonahotels.com/, you can use the Elementor Canvas template in Theme Panel > My Library 🙂

    Thread Starter vacances2000

    (@vacances2000)

    Ok, great 🙂 almost done as I got that page title and side again as well as top bar… I could manage to hidden the two first ones, but not the last one… In customizing top bar, I unchecked enable top bar yet it doesn’t disappear.. Btw can I customize that one?

    Thx anyway buddy for your help ! Appreciate it! good plus for buying a pro version 🙂

    Theme Author oceanwp

    (@oceanwp)

    You can disable them via the customizer (entire site) or the OceanWP Settings metabox (per page/post). If you want to do it via the customizer, the page title is in the General Options section.
    Yes you can customize the top bar and every part of the theme via the customizer 🙂

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Custom header issue’ is closed to new replies.