WordPress.org

Support

Support » How-To and Troubleshooting » Custom header image not showing

Custom header image not showing

  • thegh0sts
    Member

    @thegh0sts

    Hi all,

    I am building a custom theme for a site and I am attempting to get custom header images to appear. I have added in the add_theme_support (‘custom-header’); code for it in the functions.php file and nothing appears on the page.

    What am I missing? Keep in mind I am just starting out with wordpress.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Timothy Jacobs
    Participant

    @timothyblynjacobs

    Hey there,

    the add_theme_support function only enables people to choose a custom header on the back end. To actually implement it in your custom theme, you have to use another function, header_image() which returns the url of the header image.

    thegh0sts
    Member

    @thegh0sts

    oh i see, so i only got the back end going…ok.

    is there some sample code i can refer to in regards to where the code is placed?

    I’ve also been looking up tutorials on how to create custom themes so I can be more competitive when it comes to building sites for clients.

    Timothy Jacobs
    Participant

    @timothyblynjacobs

    Typically you would put it where ever you want in one of your theme files depending on how you set up your theme. Here is a tutorial.

    thegh0sts
    Member

    @thegh0sts

    excellent, will give it a try.

    i hope there isn’t much of a difference between 3.0 and 3.6.

    Michael
    Forum Moderator

    @alchymyth

    is there some sample code i can refer to

    header.php of the default theme Twenty Twelve for instance

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Custom header image not showing’ is closed to new replies.