Support » Plugin: Email Users » Custom groups not displayed on Send To Groups

  • lukePeavey

    (@lukepeavey)



    I am trying to create custom groups based on the value of user meta keys.

    My goal is to create groups that will be displayed in the dropdown menu on the Send to Groups page. I followed instructions in docs, but none of of my custom groups are displayed there. I only see the primary wordpress user groups (“administrator”, “subscriber”, etc).

    For example, I want to create a group based on the value of the meta key “nycba_positions_held”. (I know that this group has at least 1 recipient)

    I used the following code to create the group:

    
    add_action( 'mailusers_group_custom_meta_filter', 'send_to_board_members', 5 );
    
    function send_to_board_members() {
        mailusers_register_group_custom_meta_filter('Board Members', 'nycba_positions_held', 'board member');
    }
    

    I would appreciate any help. Thanks

    • This topic was modified 3 months ago by  lukePeavey.
Viewing 1 replies (of 1 total)
  • Plugin Author Mike Walsh

    (@mpwalsh8)

    The best example I have is the old “Police Department / Fire Department” example I have on my web site. It has a small example plugin I used to configure the meta filter based on an arbitrary meta key.

    I can’t recall off of the top of my head or not if the meta query is output in the debug information when Debug Mode is enabled. It might be. When Email Users is in debug mode it puts a bunch of data from the query in the generated HTML as comments so you have to look at the HTML page source to see what is reported.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.