Support » Theme: OceanWP » Custom fonts suddenly not working

  • I have Custom fonts set on most sites with no issues!
    In the last few days one site that had no issues suddenly stopped displaying custom font!
    this is affecting only pages and posts that ARE NOT created with elementor but rather rely on the CSS & customise of Ocean WP.

    Any suggestion would be most welcome

    I checked to make sure the fonts are in the fonts folder and both style.css and function.php are set up correctly.

Viewing 11 replies - 1 through 11 (of 11 total)
  • More info
    * when looking at the list of fonts in the customiser the custom fonts appear in the list as before
    * however on posts and pages where they should be displayed they do no and are being they are substituted by some default fonts
    * Browser element developer tools is showing the correct custom fonts css but it is not what is being displayed

    Hello,

    Try to disable/enable plugin one by one to check for a possible conflict. Can you share your site link so that I can check it?

    Hi Amit
    thanks for getting back
    https://prag.co.il

    Hello,

    Go to Dashboard > Elementor > Settings and check the box for the font color and styles. Check it works or not.

    • This reply was modified 1 year, 9 months ago by Amit Singh. Reason: typo

    was alway unchecked and still is
    the thing is on pages which are edited with Elementor there are no issues with it. The fonts appear as it should. Like the large headings on the home page.H1 H2 etc
    On the other hand on simple post pages the page title is overwritten and I get some generic font not even the body font.

    here are the last changes on the site in the time period of the change:
    1. SSL integration
    2. new plug in – really simple ssl
    3. plugin updates
    *Wordfence Security
    *Ninja Forms
    *Elementor (he_IL)
    *Ninja Forms
    *User Role Editor

    I have tried few things like removing those from the plugin folder – with no change
    what can I do next

    Hi Again
    Removed plugins one by one – it made no difference

    Continue to investigate and here is what I find
    SSL is seeing some folders within wordpress as mixed and although the fonts folder is located in the child theme folder and style.css has changed to reflect it, when displaying the pages I get this in console:
    Mixed Content: The page at ‘https://prag.co.il/category/%D7%AA%D7%95%D7%93%D7%A2%D7%94-%D7%97%D7%93%D7%A9%D7%94/’ was loaded over HTTPS, but requested an insecure font http://prag.co.il/wp-content/themes/ZigzagwebOceanWP/fonts/OpenSansHebrew/opensanshebrew-bold-webfont.woff’.

    However what is in the style.CSS is src: url(‘fonts/OpenSansHebrew/opensanshebrew-bolditalic-webfont.eot’);

    What can I do to refresh this site wide to reflect the changes?

    P.S. rolled back to Http:// and the issue was gone!

    To fixed mixed content error, try to install Really Simple SSL plugin. Also, if you are using Cloudflare or any other CDN service, then enable the Force HTTPS option.

    Really Simple SSL plugin is installed
    No CDN

    problem solved
    The solution, in case others experience this issue – was installing another plugin: ‘SSL Insecure Content Fixer’
    thank for your help over and out
    🙂

    Happy to hear that it is fixed and thanks for the solution.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Custom fonts suddenly not working’ is closed to new replies.