Support » Plugin: W3 Total Cache » Custom folder for cache not working

  • Because of the fact we don’t want any reference to wordpress we want to be able to use a custom folder for caching, but it does not seem to be working.

    We use this:
    define(‘W3TC_CACHE_DIR’,ABSPATH . ‘assets/cache’);

    in wp-config.php

    Folders are created (minify and page_enhanced), but nothing is being written into and the page shows a non css version when loading.
    Removing the rule makes it all work, so it’s not a problem with the server or writing rights or whatsoever.

    Thanks in advance for checking,
    Regards Joep

Viewing 2 replies - 1 through 2 (of 2 total)
  • Did this work properly in an earlier version or are you just trying this in the latest version?

    @destac, it works in the previous version and although i don’t use the new version it prolly works there too.

    @joepske83, make sure you place your line before require_once(ABSPATH . ‘wp-settings.php’); but after define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    So in your case, inside wp-config.php, it would look like this:

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    define(‘W3TC_CACHE_DIR’,ABSPATH . ‘assets/cache’);
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    If it still doesn’t work then this would seem to indicate that this option no longer works for 0.9.5+. For 0.9.4.x it still works.

    Cheers,
    Kimberly

    • This reply was modified 4 years, 1 month ago by Kimberly.
    • This reply was modified 4 years, 1 month ago by Kimberly.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Custom folder for cache not working’ is closed to new replies.