Support » Plugin: CSV Importer & Exporter » Custom Fields while importing are not showing with proper names

  • Resolved kb0000


    Some of the existing Custom Fields (in drop down menu while importing csv file and matching with Column Headings in CSV) are not showing proper names like CF: field_name instead they are shown as CF: field_xxxxxx (where xxxxxx is some number). With this I am no able to recoginse the Custom Field Name and not able to map with Column Heading.

    How to correct this issue?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author smackcoders


    What custom field plugin you are using? This is how custom fields are stored by the plugin just as other WordPress fields.


    Sorry, I am using Advanced Custom Fields plugins. But wp-ultimate-csv-importer is showing some fields correctly and some with field_xxxxxx.

    Plugin Author smackcoders


    Ok, expected. Our plugin is compatible with ACF plugina as it works different than normal Custom field plugins. Only customization is possible as it will break compatibility with other top plugins.

    I have the exact same problem. Really wish I had known this before spending hours preparing CSV specifically for your plugin!

    You said, “Ok, expected”, well why not put in your plugin’s description some kind of warning that you already KNOW your plugin and the most popular plugin for custom fields don’t work together?

    Not really sure I even understand why you say, “Only customization is possible as it will break compatibility with other top plugins.” As ACF is THEE top custom field plugin by far, you would think making your plugin work with it would increase the use of your own plugin. Infact, I’m forced to now deactivate and delete your plugin to look for another importer.

    Actually a simple fix would be if your plugin asked if one is using ACF then your plugin would simply not list any CF: field_xxxxxx (where xxxxxx is some number). There are a few ways to get them to work together, especially since ACF only uses the _postmeta table!

    Plugin Author smackcoders


    It is not simple as you said, we are still working on this. Hope you can contribute some code changes as this a free open source plugin.

    I’ve been working with ‘Advanced Custom Fields’ too and had the same issue.

    I did work out a resolution though. I saw in my case that

    • CF: address
    • CF: city
    • CF: etc.

    all worked perfectly, but

    • CF: food
    • CF: links
    • CF: website, etc.

    did not…

    Any custom field name that is labelled alphabetically higher than ‘field’ was resulting in it being named ‘CF: field_5229dbec8dec1’, etc.

    So, I appended each ‘Custom Field Name’ with a prefix of “a-“, so I now had:

    • CF: a-address
    • CF: a-city
    • CF: a-food
    • CF: a-links
    • CF: a-website

    I then set up a test post with every custom field having dummy data added which I then published – this ensures your new custom fields are all added to the database.

    Ultimate CSV Importer was then used to import all content as intended without any confusion.

    It worked perfectly… it just took me a long time to figure out how to get there!

    I hope this helps.

    Yep, I did notice everything above letter “F” didn’t have a readable field title for mapping. I can see where your use of “a-…” would work.

    I’m trying this now also. I’m certain it will work for me also.

    Great find Paulogoode!

    I’m glad I was able to help 🙂

    Now only if I could use this to do updates to fields vs ‘having’ to create post/pages with it lol.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Custom Fields while importing are not showing with proper names’ is closed to new replies.