Support » Plugin: Pods - Custom Content Types and Fields » Custom fields when adding new user

  • Resolved pperliti

    (@pperliti)


    Hi, i’m new with Pods and I faced a problem I don’t know how to manage.
    I extended the WordPress’s User object and I inserted a “telephone” field (required). When I edit an existing user I can see (and edit) the field “telephone”, but when I add a NEW user I cannot see the field (thus when I save WordPress complains about the missing required field “telephone”). Any idea of what I’m doing wrong?

    http://wordpress.org/plugins/pods/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Same behavior here. Sounds like a bug. You could pop over to https://github.com/pods-framework/pods/issues?state=open and report it there.

    Regards
    Bonsak

    Plugin Contributor Josh Pollock

    (@shelob9)

    This seems similar to this issue:
    https://github.com/pods-framework/pods/issues/1809

    I can’t reproduce the issue though, with required fields or not.

    I am testing with WordPress 3.7 and Pods 2.3.12.

    Have either of you tried testing without any other plugins installed and default theme activated, so we can see if this is a plugin or theme conflict or not?

    Strange. 3.7, Twentytwelve and only Pods 2.3.12 activated. But still no “telephone”-field in the new user screen.

    -b

    Plugin Contributor Josh Pollock

    (@shelob9)

    We need to figure out what everyone who has this issue has in common that they don’t have in common with me.

    Can everyone who has this issue please go to Pods Admin->Settings and copy the debug info up to Server Software and post it. Also please let me know whether you are testing locally or on a server, and if so, what type of hosting (shared/VPS/dedicated/cloud/etc.)? Thanks.

    My local XAMPP on OSX 10.6.7 testing environment-
    WordPress Version: 3.7
    PHP Version: 5.3.1
    MySQL Version: 5.1.44
    Server Software: Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_perl/2.0.4 Perl/v5.10.1

    Plugin Contributor Josh Pollock

    (@shelob9)

    Update. I have reproduced the issue and Scott and I found the source of the issue. Will be fixed in version 2.3.14. Thanks for identifying this issue and for your patience.

    Quick-fix and more information here:
    https://github.com/pods-framework/pods/issues/1809#issuecomment-27183937

    Plugin Author Scott Kingsley Clark

    (@sc0ttkclark)

    Pods 2.3.14 is now out

    Hi Scott. I update Pods to 2.3.14 but I cannot see the new custom field when I add a NEW user. WordPress 3.6.1. without any other plugins installed

    New custom field appear when I update user, but when I click “button Save”, fields don’t save. Also if field is required i cannot see “allert message”

    Plugin Contributor Josh Pollock

    (@shelob9)

    @rbompani-

    At this point Pods does not support editing Pods extended fields during new user registration.

    I have been able to reproduce the issue you mentioned in your second comment and reported it here: https://github.com/pods-framework/pods/issues/1811#issuecomment-27451034

    With 2.3.15 problem is solved, but i think that it isn’t user friendly. If I don’t compile required fields i see a white page with “-field- is empty” and I can’t return to original page. Is it possible to use an alert box before submit?

    Plugin Contributor Josh Pollock

    (@shelob9)

    Glad to hear the issue is resolved.
    The behavior you are describing is built in to WordPress. I also agree that is not the best UX. The option to show a popup instead would make a cool plugin or core patch.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Custom fields when adding new user’ is closed to new replies.