Support » Plugin: Advanced Custom Fields » Custom Fields have disappeared post plugin update

  • Resolved vshukla

    (@vshukla)



    I updated to the latest version of the plugin and also followed the instructions for the database.

    Now my custom fields have disappeared from both old and ‘New posts’ in the ‘Admin’ back-end.

    The fields are also no longer listed under screen options.

    Please help

Viewing 15 replies - 1 through 15 (of 16 total)
  • Same here. I have custom code relying on that meta-box and I don’t see any settings to re-enable it.

    I am having the same issue. Is there a fix to this or is there a way to go back to the old plugin?

    I tried rolling back to 5.7.5 and 5.7.4 but the issue persisted. As a workaround, you can change the default value of remove_wp_meta_box in acf.php, line 113 of 5.7.6:

    'remove_wp_meta_box' => true
    to
    'remove_wp_meta_box' => false

    The file will be overwritten in the next release, but hopefully the issue will be fixed by then.

    I’m experiencing this issue now as well – will they be providing a fix?

    guys I resolved my issue by downloading the latest ACF addon plugins FROM THE WEBSITE.
    They do not update on their own.

    The Custom Fields were still there except not visible and the solution suggested by ACF support worked for me.

    The support team told me that ACF now removes the default WP custom fields metabox in an attempt to speed up the load times of the post edit page.

    This feature can be disabled with the following code:

    add_filter(‘acf/settings/remove_wp_meta_box’, ‘__return_false’);

    You can do the addition either via the website itself or CPanel. I preferred the latter in case I made an error and did a backup first.

    • This reply was modified 4 months, 2 weeks ago by  vshukla.

    Thanks @vshukla.

    Note that the code you pasted has bad quotes. Anyone else trying should use this line instead:

    add_filter('acf/settings/remove_wp_meta_box', '__return_false');

    It looks the same, but the quotes will work better.

    Cheers,
    Vinny

    I’m not a website coder and what I shared was directly from ACF’s support desk. So I am not competent to decide which code is better or worse. If it works and I can concentrate on my business, I’m content. 🙂

    BTW, they’ve issued an update today.

    we had this problem too. thanks for the workaround. my suggestion for the plugin would be to make disabling core wp features a plugin setting option that is not enabled by default.

    • This reply was modified 4 months, 2 weeks ago by  tmuka.

    same here i had a custom field and was required for a plugin to work and is now disappeared!!! i did everything db restore,files restore, server rewind but nothing. Did you find how to restore those deleted fields back ?

    I am adding this code in functions.php but still nothing:

    add_filter('acf/settings/remove_wp_meta_box', '__return_false');

    • This reply was modified 4 months, 2 weeks ago by  csandreas1.
    • This reply was modified 4 months, 2 weeks ago by  csandreas1.
    • This reply was modified 4 months, 2 weeks ago by  csandreas1.

    The filter is working for me. Try adjusting the priority:

    add_filter( 'acf/settings/remove_wp_meta_box', '__return_false', PHP_INT_MAX, 1 );

    Also make sure you’re adding it to the right theme directory.

    Cheers,
    Vinny

    I upgraded to the latest version of Advanced Custom Fields and all the photos on my blog home page disappeared. I am holding with the previous version for now. Is there a fix in the works?

    Nothing listed here worked for me (adding the filter, changing the base code, etc). All images have disappeared from the site as @gdtharalson has described. No acf fields can be edited. I can get the images to show up by changing the (incorrect) string returned by the get_field function to an integer, and using wordpress native functions to derive my image sources, but I still can’t edit any posts. Very glad for any advice. Thanks.

    • This reply was modified 4 months, 2 weeks ago by  jschindler.

    I rolled back to version 4.4.9 and my fields have returned.

    @jschindler Yep switching to version 4.4.9 using wp-rollback plugin solved my problem as well.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.