Support » Fixing WordPress » custom fields causing unresponsive script error

  • was running 2.5 fine, now i’m getting this error all the time.

    whenever i go into write post/pages section of my dashboard, browser would run so slow, browser would crash most of the time.

    100’s of duplicates of boxes under “custom fields” section are created.

Viewing 15 replies - 1 through 15 (of 20 total)
  • I got the same issue: when i write a new post, the page take at least 10 sec to load. Safari warning me that a slow script take too long. And i have 100 custom fields fill up with the data of previous post.

    If i edit a old post, everything is fine.

    having same issue, but weird thing is … blog was designed on my development site where everything works fine & still does (WP2.5.1), but when I moved everything to client’s domain (WP 2.5.1) I started having this problem.

    I had the same problem.
    The error was caused by the database. I imported the posts (also existing posts). But this import also made new records in the wp_postmeta table with a postid 0.

    After running this query the problem was fixed:
    DELETE FROM wp_postmeta WHERE post_id = 0

    Leugens,

    Thanks for that bit of code. Ran the query and then checked … it cleared the problem.

    I’ve been having this problem for two weeks now and I’ve been driving myself crazy trying to figure it out. Finally got smart enough to find out where the bug was and wound up here. I did the same thing Leugens did with the importing of posts, but I have no idea how run a query. can someone give me a tip? Do I do that in myphpAdmin or whatever I’m using?

    Er…nevermind…I figured it out and it worked. I can blog again!

    Thanks Leugens! This corrected the issue that I was having.

    right so how DO you query it?
    And then what?
    While I’m thankful there is a way to finally fix my site i’m now just a man with a fishing rod but no line or hook…

    I’ve tried searching for a guide both in these forums AND the net but not found any as of yet. CONFUSION!

    scouser..

    I’m going to assume that you are able to do this, and comfortable to go into your pHpMyAdmin. Once in, locate your database that WordPress is installed on. Click. On the next page you will see a structure with tables. The one that you are looking for is called wp_postmeta. Now, click on the Browse icon for wp_postmeta. On this next page click on the post_id to arrange it so that it is showing “0” as the post id. Then tick the check box, and click delete. I found the easiest way for me was to show more than 30 rows, then they were all showing as “0”, I was able to “check all” hit delete and this way it was not one delete at a time.

    This is just how I did it. Someone out here may have an easier method, but this worked for me. Just be sure to delete ONLY those with a post_id of “0” .. and if you’re not comfortable doing this.. then don’t.

    Disclaimer: These directions are as-is and I take no responsibility once someone decides to go into their pHpMyAdmin. I’m simply trying to show what I did to correct this for me.

    Good luck!

    Leugens, you are my hero. I think my install was screwed up since my initial import, but it became more pronounced once I upgraded to 2.5.1.

    Thanks for the help and informative guide guys ^^ Problem solved.

    I can verify that this problem exists upon importing. I have duplicated the error three separate times now. I haven’t tried the “fix” yet, but am wondering if anyone is working on debugging the code that causes the problem in the first place rather than cleaning up the database after it happens.

    I just upgraded to 2.5.1 today, and I am having the same unresponsive script problem.

    I have Blue Host and use Firefox, but the problem occurs in any browser. My flash image uploader freezes when I push “upload image” and when I load the “Write Page” page it freezes momentarily and says “unresponsive script.”

    I have no idea where pHpAdmin is, but I know how to access my wp-admin files. Is it in there somewhere? I’ve looked everwhere for the postmeta file.

    Thank you for any help!

    KathyEats: pHpMyAdmin is not part of WordPress. It’s part of your cPanel (control panel) and you can locate it through your host.

    SLG – I found the pHpMyAdmin, found the wp_postmeta file. Found the postid stuff, but I don’t feel confident deleting anything because I think my Blue Host admin area looks different than the situation you described above. Any advice on this? Should I hire a computer whiz in my town to come help me?

    Thanks for your help!

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘custom fields causing unresponsive script error’ is closed to new replies.