Support » Plugin: Polylang » “Custom fields” and “Features and amenities” translations of WpResidence theme

  • Hi everyone.
    I ask for support on the forum because I believe it is the last resource I have left and I hope here there may be someone who can help me.

    Preliminary remark:
    – I’ve already consulted all the Polylang documentation, without success
    – I did a search on the forum and in Google, without finding solutions
    – I’ve done the necessary tests on the theme and plugins, but I haven’t found any conflicts.

    Moreover:
    WordPress, the theme (WpResidence), Polylang and all the other plugins are been updated to the latest version.

    More information:
    – permalinks are set to “PostName”
    – I’m using a static Home Page
    – Unfortunately, the site in question (https://www.immoprimus.ch/) is not yet public.

    My Polylang settings:
    – Default language: italian
    – Second language: german
    – the option “URL modifications” is set to “The language is set from the directory name in pretty permaliks”
    – the option “Hide URL language information for default language” is enabled
    – the option “Remove /language/ in pretty permaliks” is selected
    – the option “Home Page URL contains the language code…” is enabled
    – the options “Detect browser language” and “Media” (languages and translations) are activated
    – I have not selected any “custom posts” and I have selected all “custom taxonomies”
    – I have selected all the synchronization options, except “Custom fields”.

    I use Loco Translate to do the translations from English to Italian and German and Polylang to manage the switch of the two languages.

    Everything works perfectly, except for a couple of details: the “Custom fields” of the properties descriptions and the custom “Features and amenities” don’t switch.

    WpResidence, for those who don’t know it, is a premium real estate theme and allows you to create some custom descriptions that are inserted in the pages of the properties.

    First of all, I tried to select the option to synchronize the “Custom Fields”, but nothing changes. I keep it unchecked because it affects negatively with the management of the slider of the home page when switching from one language to another.

    So I searched in the .po file, but they aren’t written anywhere and it’s impossible to translate them with Loco Translate.
    I also tried to insert them manually (without references…) and then translating them with Loco, but obviously they were not recognized by Polylang and on the site were not translated…

    Then I tried to contact WpResidence support, as it was a premium theme, but unfortunately Polylang was not tested by them (they preferred WPML, as also described in their documentation) and so they couldn’t help me…

    Has anyone else encountered this issue?

    I think the only way would be to use string translations, but these are not detected by Polylang.
    I also tried to install the Polylang Theme Strings plugin, but that didn’t help either.

    I don’t know what to try anymore…

    Can someone help me?

    Thanks in advance to anyone who wants to try it.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • I ‘v got the same issue on my side 🙁

    WpResidence support tell me to ask here…

    lekiend

    (@lekiend)

    I have same issue for Features and Amenities with WPML.

    I’m able to translate them in “string translations” but terms are not translated in advanced search forms.

    They are correctly translated in single property page.

    Dimitri

    me too, i translated, but the proferty catalogues not translated in the advance search form.

    Search terms in string translation and replace whitespace by underscore.

    If you have a term like “Outside parking”, search “Outside_parking” and translate it to your language.

    It worked for me 😉

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘“Custom fields” and “Features and amenities” translations of WpResidence theme’ is closed to new replies.