Support » Fixing WordPress » Custom field with name “enclosure” disappears on save

  • animepulse

    (@animepulse)


    I have been using custom fields with type “enclosure” and “itunes:duration” for 3 years in wordpress to do podcasting. With 2.8 all of a sudden if I save a post, the “enclosure” custom field disappears. On a new post I can add it and save and it is there. But then if I ever go back in to update the same post the enclosure field disappears on page load. I can re-add it, but then when I click “update post” and the page reloads it is gone again. This only happens with a custom field with the name “enclosure”, and it happens every time on every post, even old posts. Any ideas?

    Thanks,

    Animepulse

Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi

    (@esmi)

    Have you tried:

    – disabling Google Gears if you have that running/installed.

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems.

    renaming the plugins folder via FTP

    – reading http://wordpress.org/support/topic/279132

    animepulse

    (@animepulse)

    Thanks esmi, by following those steps I was able to narrow it down to the a bug in the podpress plugin.

    Thanks,

    Animepulse

    sdhunt

    (@sdhunt)

    I’ve tried all of the suggestions above but still have the same result animepulse describes.
    The custom field “enclosure” usually gets removed after I save the post.
    Strangely it doesn’t act 100% consistently. Sometimes(and sometimes not) on the second save attempt the enclosure field does remain but then if I view the post the enclosure data is gone and when I go to edit the post again the enclosure field is missing.

    I don’t have the podpress plugin. I have disabled all plugins, changed to the default theme and I don’t use Gears.

    Any help would be so appreciated!

    I was having the same problem. Unfortunately, it looks like this behavior is considered a “bug fix”, and was coded right into WordPress 2.8. See the “bug” listed in WordPress Trac: ticket #6840. (I found this out by reading the changelog of the plugin ‘Podcasting’, under the header for version 2.2; it’s referred to there as the “enclosure prune” bug.)

    A temporary fix I’m using is to add to the post’s body a redundant copy of the the URL I’m putting in the ‘enclosure’ custom field. A little messy, but it appears to do the trick.

    Thanks MJAYAS,

    This is seriously messed up behavior, and very sloppy in terms of putting the URL in the body.

    What I’m confused now about is whether this is now considered a bug, and will be fixed, or should we figure out a way of engineering around the sloppiness of having a redundant URL and also figure out how to add these to the thousands of posts we have…grrrr.

    I never understood the desire for the auto-enclosure thing. I’ve always thought it was annoying, restrictive and problematic.

    Ok,

    I found a better way, but it requires editing functions.php. See:
    http://kevinjedwards.com/51/how-to-stop-wordpress-28-from-deleting-enclosures/

    Just delete or comment out lines 1164-1168

    I’ve logged a new bug about this issue at http://core.trac.wordpress.org/ticket/10511

    Thanks at lot for the info Kevine,

    Animepulse

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Custom field with name “enclosure” disappears on save’ is closed to new replies.