Support » Plugin: Improved user search in backend » Custom field search box values won't save

Viewing 5 replies - 1 through 5 (of 5 total)
  • I resolved this myself by adding the option manually to the wp_options table. Once I did that, searches included the meta fields I added. This is a fabulous, simple plugin, but I’m afraid for its future if it’s not getting any love from its developer(s).

    INSERT INTO wp_db.wp_options (option_id, option_name, option_value, autoload)
    VALUES (NULL, 'iusib_meta_fields', 'business_name,business_dba', 'no');

    Thanks BertPC I used this trick myself, albeit with a much larger set of meta fields, and it’s working perfect. Had the same problem with the save function not working but this bypassed it and it’s working now 🙂

    Garrett Hyder

    (@garrett-eclipse)

    I had a similar issue where it saved initially but trying to save it as empty failed.
    Updating line 97 to update if empty seemed to do the trick;
    if(empty($sanitized) || preg_match('/^[a-zA-Z0-9,]+$/',$sanitized)) {
    Hope that helps someone,
    Cheers

    Garrett, that code will work to allow saving of an empty string, but I assume that most people that are having issues are including underscores (_) in their meta fields. To allow underscores, line 97 can be updated to:

    if ( empty( $sanitized ) || preg_match( '/^[a-zA-Z0-9,_]+$/', $sanitized ) ) {

    Thanks @dale3h, good call.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Custom field search box values won't save’ is closed to new replies.