Support » Plugin: Post Expirator » Custom Field Question

  • Hi,
    I am trying to configure a plugin (Content Views Pro: https://www.contentviewspro.com/) to use a Post Expirator custom field (that seems to be available) to filter posts by their expiry date (if it is NOT past the expiration date).

    The Post Expirator fields that I see that I am trying to use are:
    _expiration-date
    _expiration-date-options
    _expiration-date-status

    Value Types the CV Pro plugin offers to filter by are:
    -Text
    -Number
    -Date
    -Date Time
    -True/False

    and the Operators to compare by are:
    Now & Past
    Now & Future
    In the Past
    Equal (=)
    Differ (!=)
    Greater (>)
    Greater or Equal (>=)
    Less (<)
    Less or Equal (<=)
    Between
    Not Between
    Exists
    Not Exists

    I have tried many combinations and have not been able to create an action based on when a Post has not yet expired.

    So for example, I have tried:
    _expiration-date
    Date Time
    Now & Future

    Here is a screenshot of the configuration screen for the plugin:
    https://drive.google.com/open?id=0B7emYW3bxgrfY2V3ZFYxNkhSZ0E

    The 4th field is a blank field, “Vale to Compare,” which I’ve been leaving blank.

    Do you have any guidance you can offer? Or documentation?

    Thanks!
    j

    • This topic was modified 2 years, 2 months ago by jacquid. Reason: added screenshot
    • This topic was modified 2 years, 2 months ago by jacquid.
    • This topic was modified 2 years, 2 months ago by jacquid.
    • This topic was modified 2 years, 2 months ago by jacquid.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Nevermind my above post for the moment. I only need that if Expirator is functioning properly, but I found my core issue here is that posts aren’t expiring. I have them set to move to trash and the expiration date passes and nothing happens.
    I see the posts in the Cron Schedule and Debug Logs being scheduled, but nothing fires. I am not even sure what I should be seeing in the debug log if it is successful, as I’ve never seen it happen. No email notification either.

    Are there some suggestions you can make for me to check? Server config, settings, something glaring I’m missing? Sorry, I couldn’t find documentation for this.

    Also, can you use this to delete Media Library items? I see the option in the Media Library attachment details page, but when I set and save a date/time and revisit, it’s undone… Not sure why it’d be available in the Media Library if they can’t be set to expire.

    Thanks so much!
    j

    OK, well I could not figure out how to get Post Expirator to work.

    This plugin does work though: https://wordpress.org/plugins/va-simple-expires/

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Custom Field Question’ is closed to new replies.