Support » Plugins » Custom Field Images Not Working

  • Resolved rickmesser


    New to WordPress/PHP good with XHTML/CSS.

    I had this site working with the plug-in “Custom Field Images” working correctly. I migrated from “Hostmonster” to a new host “Media Temple” and everything works great except for the Custom Field Images.

    They simply don’t show up when viewing and when I go into the editor at the bottom of the page where you add a “CFI” I get this message:

    Warning: Invalid argument supplied for foreach() in /nfs/c02/h10/mnt/18187/domains/ on line 62

    Here’s what it says on admin.php on line 62:

    foreach ( self::$data as $key => $value )

    I’ve tried deactivating, deleting, and re-installing but I keep getting the same warning.

    Could this be a permissions issue? If so, what do I need them to be?

    Can someone help?

Viewing 6 replies - 1 through 6 (of 6 total)
  • If u have reinstall the plugin, then it may not be plugin issue…

    But again, when u migrate from your previous provider to the new provider. are you using the same WordPress version?

    If no, that might be a compatibility issue if u are using a newer version in your new hosting provider…

    Besides that, it might be permission issue to on folder where u store your images..try to change chmod to 777…see if that would help

    Yes, I am running the same version of WordPress… The latest: 2.8.6

    I’m just uploading the images as I assign them as a Custom Field Image. So I just put that permission (777) for the whole uploads folder (wp-content/uploads)? I’ve never really understood the permissions thing.

    Noted..if that is the case, most likely it is not the wordpress version is causing the issue..although the plugin page

  • indicate it is compatible up to 2.8.5.

    Most likely a permission issue here we are looking at…you are right, set chmod 777 on the uploads folder(wp-content/uploads)..if u are using FTP like Filezilla, u may choose to set 777 to recurse into all folder and files….

    That may help to fix the issue…if issue persists, try to disable ALL plugins and left custom field image remain activated…

    If issue does not persists, it could be one of the added plugin may conflict to custom field image…

    That would be plugin i do come across lots of issue like this is that may due to plugin conflict or theme compatibility…

Hmm… Kinda weird. Changed permissions on uploads and subsequent folders. I disabled all plug-ins and the warning was still there. I enabled them all again and tried adding a CFI anyway and it worked. But the warning message is still there??

Just so strange because it worked fine on the host I had it on before this one. I DID read that about CFI only being compatible up to 2.8.5 but I’m running 2.8.6 on the host I moved it from and I’m not getting that same warning.

Thanks for your help. I would like to get the warning off of there so I don’t look like a hack to my client who will be managing content, but this is working for now. Just hope it doesn’t fall apart on the next upgrade!

Well that is weird..most likely it could be plugin compatibility issue..

Perhaps leave it for now..and wait for the next update release on that plugin…

If issue persist after next upgrade, perhaps u should email the plugin developer to describe the weird incidence…

Well, I’m not sure why but on the pages that I inserted a Custom Field Image into, after a day, the warning went away. However the warning is still on all the pages that do not have a “CFI”. Seems like it goes away when I put one in.

Thank-you so much for your help. In the end I think it was a permissions issue…

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Custom Field Images Not Working’ is closed to new replies.