Support » Plugin: Toolset Types - Custom Post Types, Custom Fields and Taxonomies » Custom Feild URL not linking out correctly

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi AmandaBergsma,

    Hope you are using Types and WordPress latest. Please share the code that you are using for listing URL values.

    [ Signature moderated. ]

    I think the simple question is: How to make the link open in a new window automatically, using the standard target=”_blank” code.

    For example, how would I assure that your string opens the following output in a new window (because it doesn’t):

    <?php echo(types_render_field("sitio", array("show_name"=>"true","output"=>"html"))); ?>

    Thanks.

    Hi mangoman,

    Sorry this feature is not supported in Types. We are considering it in futures.

    [ Signature moderated. ]

    Hello

    I have set up a Custom Post type “Business Directory”

    In that, I have a Custom Field I am using the “URL” one and attaching to it to see in a “Business Directory”.

    In the template I am using the following code:

    <b>Web:</b> <?php echo(types_render_field("website", array())); ?><br/>

    I can get the like to show up and link, but like before it is already adding my domain in front of theirs.

    “http://greaterthoroldbusinesscouncil.com/www.cibc.com”
    instead of
    “http://www.cibc.com”

    I have the exact same set up for the email, and that works with no problems.

    Hello

    I figured out the problem. In the field, they where not adding the ” http://” in front of the “www.etc.com” Therefor it was not linking out correctly.

    Is there a way to update the code so the display name can be different then the link?

    Actually, when the http:// is in the field, it functions but it still doesn’t open in a new tab/window. 🙁

    Something this standard should be the default functionality (as well as auto-detecting if http:// is present or not). I tried several ‘external links’ plugins – but they didn’t work with Types, so if you know how to modify the code to achieve this “target=_blank” behavior in the links, please let me/us know!

    Thanks!

    Hi AmandaBergsma & Mangoman,

    We will try to incorporate this features in upcoming version. Thanks your feedback.

    [ Signature moderated. ]

    That would be great!

    Meanwhile, I installed & tested the WP External Links plugin to achieve the <target=”_blank”> function. That plugin is available here:
    http://www.freelancephp.net/wp-external-links-plugin/

    Thanks again for your support.

    Hi Mangoman,

    Thank you for the updates. You are welcome.

    [ Signature moderated. ]

    Thanks.

    I recommend using the WP External Links plugin until they include this feature. 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Custom Feild URL not linking out correctly’ is closed to new replies.