Support » Fixing WordPress » Custom Error establishing a database connection page doesn’t show

  • Gabi

    (@vici)


    Hello,
    My host is currently experiencing some Denial of Service issues and it means that all my sites are actually down.
    So I wanted to add a custom error message for my visitors to ensure that it’s a temporary problem.
    I added a db-error.php page to the wp-config directory with a nice message, but it shows only when I access my wp-admin.php page. I’d like my visitors to see the nice message too instead of <h1>Error establishing a database connection</h1>
    What should I do?
    here’s my url: fashion-allure.com/style

Viewing 3 replies - 1 through 3 (of 3 total)
  • MichaelH

    (@michaelh)

    That message is in wp-includes/functions.php and wp-includes/wp-db.php if you were of the mind to change it in core.

    Can you tell me how I can fix this error? I just uploaded my site from local to host and received this error from the functions.php file. The error points to an “else” statement.

    Thank you for any help!

    Leslie

    I just read another post of yours saying to check the DB_NAME, DB_HOST, DB_PASSWORD, DB_USER settings. I think this is my problem as I have moved my file from a local usage to my host server. I will check these settings and hope this fixes my problem. Thank you for the lead…

    Leslie

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Custom Error establishing a database connection page doesn’t show’ is closed to new replies.