• Resolved chevas

    (@chevas)


    You fixed an issue about a month ago where a user had set the range to 7 days, but it was showing top posts from the current day only. You released v 2.6.1 to fix this issue.

    I am on v 2.6.2 and I am experiencing the exact same issue. I am using the widget, I set it to a very large 60 days, but it still shows only posts from today.

    I removed the override in the widget and set the plugin itself (in settings) to 60 days and I still am only seeing stories with page views from today.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Ajay

    (@ajay)

    Did this work in version 2.6.1 for you?
    I can’t see what I changed in v2.6.2 that could have changed this again.

    Can you try to reset the settings + delete and readd the widget (and save widget settings) and see if this fixes the issue?

    Thread Starter chevas

    (@chevas)

    Thanks for the response. I reset the settings in the plugin area. I then deleted the widget, then re-added the widget. I changed the settings to day range (and set it to 7) and ensured I saved settings. It still only shows top posts based on today’s views. I also tried 60 days, but still only shows the top posts based on today’s views.

    I also double-checked my post view counts. The post with the most views in the last 60 days is definitely not showing up as the top post when I set the “Custom Time Period” to 60 days. The same is true for 7. “Custom Time Period” in the widget is always showing the top posts from today, no matter what value I set.

    I also attempted to set the day range to 0 and the hours range to 168 (7 days) to see if that worked, but no go.

    I have not tried version 2.6.1

    Plugin Settings:
    https://www.dropbox.com/s/4nynija14m70ycl/top10-plugin-settings.png?dl=0

    Widget Settings:
    https://www.dropbox.com/s/6o3j7g6mq3pl4hi/top10-widget-settings.png?dl=0

    • This reply was modified 5 years, 1 month ago by chevas.
    Plugin Author Ajay

    (@ajay)

    The settings definitely look fine. I have to admit that I am confused as I can’t replicate this in all my installs.

    Can you please check:
    1. What is your setting for Published age of posts in the Posts list tab?
    2. What do you see in the Dashboard widgets which are governed by the settings – i.e. /wp-admin/
    3. If you navigate to Top 10 > Daily popular, you will see the posts of the last day – what is the count when you toggle the range there for say a custom period of 10 days (both dates are included)

    Lastly, if all this doesn’t given the results, are you in a position to see the queries the plugin generates for the widget – you will need to do this with the cache off. Using Query Monitor plugin

    Thread Starter chevas

    (@chevas)

    Ajay, I apologize for taking you down this rabbit trail, but I learned something. Correct me if I’m wrong, but it appears that if I go in and manually override the total page view count, that value is ignored in the daily range tracker, but it is calculated in “overall”.

    When I installed the plugin, I went through all my URLs for each post in Google Analytics and gathered the page view values within a 60 day range. I then took these values and added them into your plugin’s page view count field, on each post (it took a while). I did this a little less than a week ago so I figured your plugin would count these as “page views within 7 days”. That is not the case.

    I was hoping to simulate what was popular over the past 60 days, even though I didn’t have the plugin installed. Now that you’ve taken me through the various places your plugin tracks, I can see that the counters are all working properly, starting on the day the plugin was installed.

    Is there any way to accomplish what I was trying to do? If not, it’s still a great plugin. Everything is self-hosted and I have access to the stack and file system.

    • This reply was modified 5 years, 1 month ago by chevas.
    Plugin Author Ajay

    (@ajay)

    That explains 🙂

    There is potentially a way to do what you’re doing – you’d need to get your popular posts view count on a day by day basis i.e. hits per day – get them in a CSV or a mySQL insert format and insert these directly into the database – wp_top_ten_daily table.

    You should see how the format of the current tracked posts is and you’ll need to use that same format.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Custom Day Range Not Applying’ is closed to new replies.