Support » Plugin: WordPress Popular Posts » Custom css style

  • Resolved Raoul1

    (@raoul1)



    Hey,

    I’m new to coding and I’m having trouble in getting the popular posts plugin look right. Basically I’m trying to make it look exactly the same as my “recent posts extended” already does.

    This is the custom css I used:

    .rpwe-block ul{
    list-style: none !important;
    margin-left: 0 !important;
    padding-left: 0 !important;
    }

    .rpwe-block li{
    border-bottom: 1px solid #eee;
    margin-bottom: 10px;
    padding-bottom: 10px;
    list-style-type: none;
    }

    .rpwe-block a{
    display: inline !important;
    text-decoration: none;
    }

    .rpwe-block h3{
    background: none !important;
    clear: none;
    margin-bottom: 0 !important;
    margin-top: 0 !important;
    font-weight: 400;
    font-size: 15px !important;
    line-height: 1.5em;
    }

    .rpwe-thumb{
    border: 1px solid #eee !important;
    box-shadow: none !important;
    margin: 2px 10px 2px 0;
    padding: 3px !important;
    }

    .rpwe-summary{
    font-size: 12px;
    }

    .rpwe-time{
    color: #bbb;
    font-size: 11px;
    }

    .rpwe-comment{
    color: #bbb;
    font-size: 11px;
    padding-left: 5px;
    }

    .rpwe-alignleft{
    display: inline;
    float: left;
    }

    .rpwe-alignright{
    display: inline;
    float: right;
    }

    .rpwe-aligncenter{
    display: block;
    margin-left: auto;
    margin-right: auto;
    }

    .rpwe-clearfix:before,
    .rpwe-clearfix:after{
    content: “”;
    display: table !important;
    }

    .rpwe-clearfix:after{
    clear: both;
    }

    .rpwe-clearfix{
    zoom: 1;
    }

    https://wordpress.org/plugins/wordpress-popular-posts/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Hector Cabrera

    (@hcabrera)

    Hi there!

    Hard to tell what might be happening without seeing your site 😛 Please, share your URL so I can take a look.

    Oh, sorry! 😀

    Here!

    Plugin Author Hector Cabrera

    (@hcabrera)

    It seems the WPP widget isn’t active on your site at the moment. I can’t tell what you should change to make it match RPE’s style unless you add it back.

    Okay now it’s on!

    Plugin Author Hector Cabrera

    (@hcabrera)

    Thanks 🙂

    Alright, try this:

    1. Go to Widgets > WordPress Popular Posts, enable the “Use custom HTML Markup” checkbox under Custom HTML Markup, and hit the Save button.
    2. Set the Before / after Popular Posts fields to <div class="rpwe-block"><ul class="rpwe-ul"> and </ul></div>, respectively.
    3. Set the Post HTML Markup field to <li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title">{title}</h3><time class="rpwe-time published">{date}</time></li>.
    4. Hit the Save button.

    Let me know how it goes, ok?

    Yes, it’s perfect! Thank you so much, I really appreciate it!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Custom css style’ is closed to new replies.