Support » Plugin: TablePress » Custom CSS not applying…

Viewing 7 replies - 1 through 7 (of 7 total)
  • Depending on your theme, you might have inherited styles being past down to your table elements. To get your code to bypass the inherited styling, add !important to your CSS. Here’s an example:

    .tablepress-id-2 .column-2 {
    	width: 35% !important;
    }

    Still didn’t resolve my issue. I’m trying to remove the sorting arrows (while maintaining sorting ability) AND change font size. Adding the !important; didn’t work.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble.

    Unfortunately, I can’t really help where without actually seeing the site. Can you therefore please post a link? I’ll then try to find out why the “Custom CSS” is not working.

    Thanks!
    Tobias

    Sure. It’s http://pbcmesquite.org/media/preaching

    I removed the sorting option because the arrows looked bad.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for the link.

    From what I can see, you have inserted some “Custom CSS”, but did not adjust the table ID. As mentioned in the FAQ entries from where you got the code, you need to adjust the ID from N to the ID of the table that you want to change. In the other part of the code, you need to adjust the 123 to the correct ID. This should be 1 in your case.
    (If you want to have the code apply to all tables at once, just replace .tablepress-id-123 and .tablepress-id-N by .tablepress.)

    After that, the sorting arrows will be gone, so that you can enable the sorting ability again. Also, the font will change.

    Regards,
    Tobias

    Done! Fixed! Thanks so much!

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    sure, no problem! You are welcome!
    Good to hear that this helped!

    Best wishes,
    Tobias

    P.S.: In case you haven’t, please rate TablePress here in the plugin directory. Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Custom CSS not applying…’ is closed to new replies.