Support » Localhost Installs » Custom CSS in “Additional CSS” seems disabled until I start editing the CSS

  • zehgs

    (@zehgs)


    Hi everyone!

    I’m a newb making my own website. I have a good deal of CSS in the “Additional CSS” area of Customize. When I open any page using its localhost address as if I were visiting my website as a customer, none of the custom CSS that I have has any effect whatsoever anywhere. When I first open Appearance > Customize, the same thing also always happens at first.

    If I then change one single comma, anything at all in the content inside “Additional CSS”, all of the CSS instantly gets “turned on” and affects the site, no need to even press “Publish”. In other words, all of the custom CSS is only ever active while I am working on the website.

    Why is this happening? I would like to be able to access and use my website from the localhost link. The problem persists when accessing using incognito or another browser.

    Thanks a lot!

    NOTE: I don’t know if this is relevant but I do have Elementor and Elementor Pro, though I don’t think I’m using any CSS there.

    • This topic was modified 1 month ago by zehgs.
    • This topic was modified 1 month ago by zehgs.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Kaavya Iyer

    (@kaavyaiyer)

    Hi @zehgs,

    Which theme are you using for your website?
    Please try disabling all plugins and check if the CSS is reflecting.

    Thread Starter zehgs

    (@zehgs)

    Hi Kaavya!

    Thank you very much for replying!

    I am using Shoptimizer, which I had done in the past without any problems. Unfortunately disabling all plugins didn’t help. I have very few of them at the moment:

    https://i.ibb.co/ZBcVRHP/image.png

    What else could I try?

    EDIT: Moving everything to Elementor worked but only partially. The CSS looked weird within Elementor’s editor but looked mostly right for the main page when viewed normally. Unfortunately, it looked wrong for the product page.

    • This reply was modified 1 month ago by zehgs.
    Anonymous User 20836990

    (@anonymized-20836990)

    Hi @zehgs!

    I don’t know if this will help but I have a workaround for a similar problem:

    1. Press “F12” then “CTRL” + “SHIFT” + “P”. These commands will open DevTools and run Command Palette.
    2. Look for “Disable cache” then press “Enter”.
    3. Keep the DevTools open while publishing a CSS change.
    4. Press “F5” to reload site.

    Let me know if this worked.

    • This reply was modified 1 month ago by Anonymous User 20836990.
    Thread Starter zehgs

    (@zehgs)

    Hi @wpspecialist !

    Thank you so much for replying.

    Unfortunately this did not work. Anything else I could try?

    EDIT: before I tried your suggestion I noticed that the CSS does seem to apply to the main page only and nowhere else. This is odd as I was working on the product page and most of the CSS I am really interested in is there at the moment. I know the CSS is correct as all I need to do is change anything in the text and it will magically take effect.

    EDIT 2:: moving the CSS directly into the stylesheet in the “Theme File Editor” area under the Appearance menu did the trick and it looks the way it should. Does this shed light on the issue?

    • This reply was modified 1 month ago by zehgs.
    • This reply was modified 1 month ago by zehgs.
    Anonymous User 20836990

    (@anonymized-20836990)

    Oh, I misunderstood your problem. XAMPP/”localhost link” is not connected to your live site and you can’t use XAMPP to host your website. XAMPP is only for testing and learning stuff out.

    • This reply was modified 1 month ago by Anonymous User 20836990.
    Thread Starter zehgs

    (@zehgs)

    Oh so this problem will go away when I go live? I still haven’t paid for the hosting service so I’m using it. Also it’s faster

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.