Support » Themes and Templates » Custom css file not working properly after site migration

  • Little bit of a novice here, and I’m having a small issue.

    I just migrated a wordpress site from a localhost to a live server. After a few tries, I eventually got everything to transfer over and function properly, except for the css edits.

    Under the admin panel and the them editor, my custom edits to the css are still present, but for some reason they’re not showing up on the site pages.

    No idea what happened here, any help would be appreciated

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator stephencottontail

    (@stephencottontail)

    Can you post a link to your site?

    sure it’s http://cttemp.com/

    Update: I just deleted the whole css file (after making a copy on my desktop). If that file was what the site was loading it’s content from it should have broken the webpage right? but nothing changed on the site at all.

    I can’t find another css file anywhere in the site database that it would be loading from. is it possible it’s still linking back to some other file from before the migration?

    Moderator stephencottontail

    (@stephencottontail)

    When I look at your site (9pm, Mountain time), your stylesheets appear to be loading correctly, but I am getting a 404 error for wp-content/themes/bostan/framework/aqua/assets/css/aqpb-view.css?ver=1420988534. Can you post an example of a CSS rule that isn’t working? Do you receive any errors when you edit or upload any files?

    I haven’t received any error when uploading files, eveything seems to be going smoothly.
    A big problem with css occurs on this page:

    I have all of the following in the theme css editor tool in the wordpress admin panel. However none of it seems to be showing up on when i pull inspect the site with chomes developer tools.

    .plan_price{
    font-size: 1.5em;
    line-height: 1.3em;
    height: 150px;
    }
    
    .pricingcontainer {
    max-width: 90%;
    margin-left: auto;
    margin-right: auto;
    }
    
    .feature_desc {
    color: #4E4E4E;
    font-family: arial;
    text-align: center;
    height: 35px;
    }
    
    .pricingcontainer .three.columns {
    width: 33.33333333%;
    padding: 5px;
    }

    Is it possible that the site isn’t reading the edits to the css I make through the wordpress admin panel?

    I’m not sure what that 404 error means for the code, And I ‘m not sure where to begin looking to fix it. I’ve never encountered an issue like this before :/

    Moderator stephencottontail

    (@stephencottontail)

    What file did you edit? I don’t see the listed CSS rules in any of your stylesheets.

    A 404 error means that the website asked the browser to load a particular file and the browser couldn’t find it. I don’t see that particular error anymore, though.

    I was using the WordPress admin panel’s theme editor tool to edit the css. So it’s Admin panel > Appearance > editor.

    I’ve just pulled up the style sheet for the site through ftp, and the edits I made are definitely present within that file. Located: wp-content/Themes/bostan/style.css .

    Moderator stephencottontail

    (@stephencottontail)

    Are you using a caching plugin? If so, you should temporarily disable it while you edit your site. Also, is your host caching your site? If so, you should ask them how to flush their cache.

    I’m not using a cache plugin that I know of, (none show up under my plugins folder). I use godaddy for hosting, and I’m trying to get in touch with them now to see if they cached anything. I’ll get back to you once i get some help from them.

    Thank you for your help by the way. I really appreciate it.

    Ok, I got Godaddy to clear the cache. Doesn’t look like it helped at all though 🙁

    Moderator stephencottontail

    (@stephencottontail)

    Hmm. You might also consider speaking to your theme’s author, as well.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Custom css file not working properly after site migration’ is closed to new replies.