Support » Plugin: Woocommerce Google Feed Manager » Custom Color Options Not Working

  • Resolved mc808

    (@mc808)


    Hi,

    I had all of the colors set up last night to search the title and display a certain color. Today, when I looked, the fields were changed and were not displaying the correct information. So I deleted those, but now for some reason it won’t let me add any additional color options. Please let me know what needs to be done to get this resolved. This is the only thing holding me back now from launching my marketing campaign. So hope this can be resolved quickly.

    Thanks!

Viewing 15 replies - 1 through 15 (of 28 total)
  • Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Hello @mc808,

    Are you using a third party plugin to enter the colors to your products or are you using the standard attributes?

    Hi there, I’m using your plugin, but it’s broken. It’s so strange! Even the last option that normally displays… use this value for all other products… it’s missing! It was working fine a couple days ago.

    I wanted to submit a screenshot… but I don’t see an option to upload here…

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    You can use pasteboard to upload screenshots: https://pasteboard.co/

    Oh, great! Thank you!

    Here’s the link: https://pasteboard.co/IBDGmYN.png

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    OK @mc808 I can reproduce it so it’s a bug. I’ll start working on it tomorrow. Usually this should not be so hard to fix, so I expect to have a patch for you tomorrow as well.

    What version of our plugin are you using?

    Ok, thanks! Looks like it’s 1.16.0.

    Also, is there another way to add different sizes besides upgrading to the premium version? It’s a good plugin, but I’m not paying $70 a year just to add different sizes. Anything else you can suggest to accomplish this?

    Thanks!

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    @mc808,

    I found the cause of the issue and it will be solved in the next update.

    In the mean time you can solve the issue by using the following work-around:
    On the last color selection, select the (remove) option. That should bring the “for all other products” option again. Select “edit” and you should be able to continu your selections.

    By the way; the way you have setup the color now, without a “for all other products” selection, is not advised. This way the plugin will not now what to do with products that do not comply with any of the selections you’ve made. So it is advised to at least a source for the “for all other products” selection, even if its a “Remove from feed” selection.

    Then for the sizes; I don’t know what you mean with adding different sizes. Do you mean you want to add the product variations? If so, I’m sorry but there is no other way to add product variations to the feed. Product variations are a special kind of products and adding them to the feed requires a lot of special code that is only available in the premium versions of our plugin.

    Let me know if you were able to solve the issue using the work-around and if we can close your topic.

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    @mc808,

    Where you able to get your feeds running again, using the work-around? Can we close your topic?

    mc808

    (@mc808)

    Hi Michel,

    Thanks for checking back! Yes, I just tried and your suggestion worked for me. Thanks!

    Also, I tried using a similar plugin that I could add variable products with, but their plugin had issues too… many more than yours! And not as good support… So I suppose I WILL be buying your premium version. I just tried to purchase it now though and I’m not able to purchase it using PayPal. Too many issues trying to log into or use PayPal since I’ve been living abroad and it won’t even let me create a new account as my bank card is already tied to my old account. And I can’t access that account unless I spend like an hour on the phone dealing with their customer support. That’s what happened last time and I’m just not going to do it. It’s not worth all the hassle. I just don’t use PalPal anymore. What other options are there for making the payment? People shouldn’t be forced to create a PayPal account just to use your plugin.

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    @mc808,

    Great that it solved the issue.

    In a way you’re off course right that we should offer more options, but the issue is that for our administration and costs point of view PayPal is by far the easiest way to handle international payments.

    I’ll ask @aukejomm who’s managing the payments to see if there’s another option. Let me look into this.

    mc808

    (@mc808)

    Hi Michel,

    Actually… turns out it didn’t solve the issue. The same issue is happening again. The fields are automatically changing, even after I saved them.

    https://pasteboard.co/ID6BbPm.png
    https://pasteboard.co/ID6BsUN.png

    So this is causing the colors orange and purple to show up as multi-color, rather than orange and purple like they are supposed to.

    I just tried to make the changes again and I’m not seeing any difference in the feed.

    Also, for the payment for the premium version, a family member used their PayPal account for me. So that is settled. But I hope you will offer other options in the future. It’s not nice to be forced into opening/using a PayPal account. Your payment system gives 2 options… one is subscribing with PayPal and the other is subscribing with a credit/debit card, but even that option forces you to create a PayPal account before it will process the payment! Not nice!

    Lastly, I’m trying to install the premium version. The instructions say that in order to avoid deleting the feed (which from I understand took about a week to be approved by Google in the first place! So I definitely don’t want that to be deleted and have to start that process over again!) So I’m supposed to use FTP to install the premium version and “overwrite” the free version. But I don’t know how to do that. And again, don’t want to risk wasting another week waiting for Google to approve all of my products again! Can you give me more details or send me a link where it gives further instructions on how to do this?

    Thanks!

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Hello @mc808,

    When I look at your screenshots, I see you left a row not filled in. Could be that that causes the issue. You need to fill in all the rows and don’t leave any empty in the middle of the queue because that will confuse the query that should run on your Color settings.

    If you look at the first screenshot, the first two rows have a selection, but then the third row is not filled in whilst from the forth row you have made your selections again.

    I would suggest to remove all the rows using the remove option and then set them up again from scratch, leaving no row empty.

    Let me know if that solved the issue.

    Then when looking at a feed through your browser, be sure to use the CNTRL-F5 combination to make sure you’re not looking at a cached feed. When a feed does not look OK, first clear your browsers cache.

    To install a new version of your plugin through ftp, follow these steps:
    1) Download your premium version of the plugin from here https://www.wpmarketingrobot.com/your-account/ (click on “View details and downloads”)
    2) Deactivate the WP Product Feed Manager plugin on the Plugins page (do NOT delete it here)
    2) Open the ‘wp-content/plugins’ folder on your server
    3) Make a backup of the ‘wp-product-feed-manager’ folder and then remove the folder from the plugins folder
    4) Copy the content of the downloaded plugin file into the ‘wp-content/plugins’ folder
    5) Reactivate the WooCommerce Google Feed Manager plugin on the Plugins page
    6) Open the Feed Manager -> Settings page and press the “Clear feed process” button

    That should give you the premium version without loosing your feeds.

    mc808

    (@mc808)

    Hi Michel,

    Thanks for the quick response! Yes, I am aware that there is a line not filled in. That’s what I’m getting at. That is your plugin doing that! This is the same problem I had initially when I reached out. I have made these same changes now 3 or 4 times and your plugin automatically changes things. I don’t think I have yet tried deleting ALL of the color options and then filling them all out again. I will try that. But seems to be a deeper issue. Again, to be absolutely clear, I have NEVER left a row empty. Those are the automatic changes your plugin is making.

    Thanks for the other detailed information!

    I have just tried your suggestion. The plugin won’t even allow me to delete all the color options. It leaves 3. Now when I add the rest again, I’m still left with those 3.

    https://pasteboard.co/ID7dVYz.png
    https://pasteboard.co/ID7edt5.png
    https://pasteboard.co/ID7exg5.png

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    OK, that’s strange. I’ll have to perform some tests and think about a solution.

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Could you try the following:

    Remove all the color options.
    Then press the “Save Feed” button (not the Generate & Save Feed button).
    Refresh the page, or navigate to the Feed List and then back to the Edit Feed page again.
    and fill the color options in again?

Viewing 15 replies - 1 through 15 (of 28 total)
  • You must be logged in to reply to this topic.