Support » Plugin: Gravity Forms + Custom Post Types » Custom category taxonomy only display values

  • I have a custom post type with a custom category taxonomy set up. I can select the taxonomy under advanced in GF and it populates the choices in the radio buttons – but the values show up as the category ID number. Any time I try and change the value and update the form, it reverts back. When I test the form, it creates a new category using the ID number and doesn’t assign the post to the correct category.

    I’m using the latest version of GF and also using the Post Creation add. In the Post Creation set up, I have the Field Value set to the Category field.

    Any help would be greatly appreciated!

Viewing 12 replies - 1 through 12 (of 12 total)
  • Same here of course, is there an easy fix, @claygriffiths?

    mezzaninegold

    (@mezzaninegold)

    Same issue here. Just the category id numbers created as new categories.

    mezzaninegold

    (@mezzaninegold)

    Just to update I’m on Version 3.1.21 with GF Version 2.5.7

    mezzaninegold

    (@mezzaninegold)

    @claygriffiths It appears the conflict might be with Gravity forms own plugin >> Gravity Forms Advanced Post Creation Add-On once this was turn off it started working…

    Thread Starter bgfrancey

    (@bgfrancey)

    @mezzaninegold thanks for looking into that. Does turning off the APC add-on still allow you to create posts then?

    jaceknn

    (@jaceknn)

    @bgfrancey I checked it. After turning off APC add-on posts are still created.

    mezzaninegold

    (@mezzaninegold)

    @bgfrancey Yes.

    If you’ve used the default post fields, such as post title and body.

    I had to add those fields in and now it works.

    jaceknn

    (@jaceknn)

    @bgfrancey

    Update: I checked above on different site and when APC add-on is turned off, posts are not created. :confused

    mezzaninegold

    (@mezzaninegold)

    @jaceknn Do you have the default post creation fields in your form? Post title and post body?

    jaceknn

    (@jaceknn)

    @mezzaninegold Yes, in both I use those default fields. But also I’m using other type of fields in both.

    • This reply was modified 1 year ago by jaceknn.
    mezzaninegold

    (@mezzaninegold)

    @jaceknn I’d try turn off all other plugins, just to double check there isn’t another conflict happening.

    Plugin Author claygriffiths

    (@claygriffiths)

    Hi all,

    I looked into this, it looks like the Advanced Post Creation add-on expects a term name rather than a term ID.

    This plugin is designed to only provide a term ID as the value. We’re not planning on adding direct support for the Advanced Post Creation add-on at this time, but we do have a robust plugin called Populate Anything that you can use to populate field choices with Taxonomy Terms. Best of all, you can customize exactly what is used in the choice value and choice label.

    Also worth noting: when populating choices with this plugin (Gravity Forms + Custom Post Types), the choices will be reset to the taxonomy terms whenever you save the form.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Custom category taxonomy only display values’ is closed to new replies.