WordPress.org

Forums

The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] custom category pages (5 posts)

  1. samsin89143
    Member
    Posted 5 years ago #

    I have added custom category pages to a new site of mine, and I have done this before on other 3.01 wordpress sites. I am using the 2010 theme and I have taken the category.php page and set up category-x.php where x is the category id. I have only set up 4 category pages so far and two are working fine and 2 continue to pull the category.php page instead of the custom page. I have double, triple and quadruple checked the pages and they are identical in every way except for some text, but the coding is identical on the four category-x.php pages. I even pulled all the text off to see if that helped, no dice. I am pulling out hair on this. Does anyone have any ideas that I can use? Thanks in advance.

  2. Mark Ratledge
    Forum Moderator
    Posted 5 years ago #

    Are your posts in more than one category?

    Number your templates with a numeral right after the post title so you can see which templates are being used when you view categories.

  3. samsin89143
    Member
    Posted 5 years ago #

    Yes there are 4 posts in 4 categories so far. I'm not quite sure I understand your second statement. On the 2 categories that are using the category.php page this is at the top of each page "Category Archives:" just before the content, this does not show on the 2 categories that are pulling the custom categories pages. So, I assumed that the two that are not working correctly are pulling the category.php page. Am I wrong with this?

  4. Mark Ratledge
    Forum Moderator
    Posted 5 years ago #

    archive.php and category.php are two different files. Sounds like two categories are using the archives file instead of category.php. If you have an archives.php, rename it to old_archives.php.

  5. samsin89143
    Member
    Posted 5 years ago #

    I changed the archive.php file as you suggested to old_archive.php and those two category pages are still the same as they have been and they still say Category Archives: at the top of the page. This is maddening.

Topic Closed

This topic has been closed to new replies.

About this Topic