Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Custom 2.0 template not showing in NextGen Gallery setting selection

  • Resolved lheisey

    (@lheisey)


    I tried creating a 2.0 version template from the Legacy Templates Deprecated post but the newly created template is not showing up in the NextGen Gallery setting dropdown menu when I go to select it.

    To try to narrow down the problem I created a new local site with Local by Flywheel but still have the problem. The setup: Flywheel 5.9.8+5191, Windows 10, WordPress 5.6, PHP 7.3.5, Installed Nextgen 3.5.0, Classic Editor 1.6, used Twenty Twenty theme. I created 2 galleries and 1 album with a page for each.

    Copied

    wp-content/plugins/nextgen-
    gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/templates/thumbnails/default-view.php

    to test-view.php in the same folder. Added at line 8 for checking if template is working:
    <h3 style="color:blue;">Gallery Test</h3>

    In NextGen Gallery / Gallery Settings / Basic Thumbnails / Select View selected test-view.php and checked h3 tag was visible.

    Moved file to
    wp-content/ngg/modules/photocrati-nextgen_basic_thumbnails/templates/test-view.php
    In NextGen Gallery / Gallery Settings / Basic Thumbnails / Select View the file was not in the selection dropdown. Also tried moving it to
    wp-content/ngg/modules/photocrati-nextgen_basic_thumbnails/templates/thumbnails/test-view.php
    Again in the admin the file was not in the selection dropdown.

    Moved file back to
    wp-content/plugins/nextgen-
    gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/templates/thumbnails/test-view.php
    where it does show up in the admin dropdown.

    Is there a setting to enable checking the wp-content/ngg/modules/ path for templates?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter lheisey

    (@lheisey)

    I did manage to get the Basic Gallery 2.0 version template working in the wp-content/ngg/modules/ path. I was not putting it in the correct place. For it to work a couple of folders not in the out of the box install of the Nextgen plugin needed to be created. First the folder path
    wp-content/ngg/modules/photocrati-nextgen_basic_thumbnails/templates/
    needs to be created and my template file (test-view.php) placed in this.
    This shows up in the NextGen Gallery / Gallery Settings / Basic Thumbnails / Select View dropdown as custom/test-view.php
    A shortcode can also be used
    [ngg src="galleries" ids="2" display="basic_thumbnail" display_view="custom/test-view.php"]

    I also got the Basic Imagebrowser to work placing it as
    wp-content/ngg/modules/photocrati-nextgen_basic_imagebrowser/templates/imgbrowser-view.php

    So far I have no luck with the Compact Album and Extended Album templates. Does anyone know where these need to be placed in the wp-content/ngg/modules/ path?

    Thank you! I renamed my template to *-view.php and it showed up. That was why it was not working! Now on to solve a different issue…

    Plugin Support Benjamin

    (@benjaminowens)

    Hi @lheisey

    You need to create the directories /wp-content/ngg/modules/photocrati-nextgen_basic_compact_album and /wp-content/ngg/modules/photocrati-nextgen_basic_extended_album

    I’ve made a note that we need to document this and/or have those directories created automatically with the others, hopefully I’ll be able to fix it in the coming weeks.

    Thread Starter lheisey

    (@lheisey)

    That was the information I needed, thanks. For others don’t forget to create the templates folders inside these.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.