Support » Installing WordPress » current_user_can() error upon installation attempt

  • Resolved Doodlebee


    Hey all –

    I’m trying to install WordPress (Install4Free request) for an Italian gentleman. He wants the Italian version of it installed on his server. I got all of his information and went to the WordPress Italy website and downloaded the Italian version of WordPress 2.0.4. Unzipped, configured and upladaed – and I got an error for wp_cache. I tried disabling it, but nothing worked.

    So I went to the Codex and it says you can upload the English version, then get the .mo files and add the language in the wp_config file, and it’ll work the same way. I have a copy of the English veriosn od 2.0.4, and it’s fine – I’ve been using it to install WordPress for the last two weeks on all kinds of servers, no problem. So I know my files are just fine (I used them twice this morning, in fact, with no problems on other requests.) So, I edited the English version – put in the proper database stuff, and added “it_IT” to the language area and uplaoded the wp_config.php file. I created a lnaguages folder in the wp-includes area, and put in the Italian .mo and .po files. I went to the install page to try it this way, and I get a new error:

    Fatal error: Call to undefined function: current_user_can() in /home/laprovin/public_html/online/wordpress/wp-admin/admin.php on line 5

    Would anyone have any idea what’s up? I know my English copy is fine – so what am I doing wrong in this installation?

    What’s *really* funny is, I deleted all references to the Italian stuff (got rid of the langauges folder, removed the “it_IT” part, and reuploaded) and I get the same error when trying to install a straight-up English version (again, with the same files I’ve succesfully used twice the morning for other people).

    I should also mention that I’ve been having issues uploading the files to his server – I don’t know if it’s his server’s end or my internet connection (cable) – but once it hits the wp-includes area, any number of files will cause uploading stutters. It’s not any one particular file, but for some reason when it gets ot that folder – English or Italian version – his server just starts hiccuping.

    Any ideas on what’s going on would be appreciated. (I’ve looked for his error logs and haven’t found them yet…but if there’ any ideas in the meantime, I’d appreciate it.)

Viewing 4 replies - 1 through 4 (of 4 total)
  • maerk


    It looks like there’s a problem on the server with that particular folder (wp-includes). Delete the folder and try again, maybe? If it’s still not working, ask your hosts to check it out to see if there are any corrupted files or anything. Sometimes accessing the server by FTP doesn’t let you use folders that have problems.

    Edit: I think user_can_edit() is defined in a a file that’s usually located in wp-includes, which is why it’s throwing the error.



    Delete the folder and try again, maybe?

    Well, I did that already – with both the English version and the Italian one. The final attempt was to actually install the files one-by-one (I would manually create the folders rather than just uplaoding them in bulk, then open them up and install each file one at a time) – when I did it that way, everything uploaded without stuttering at all – so my guess was that the server has some kind of…I don’t know…limit on how many bytes you can transfer at once or something?

    Well, anyway, I found the error logs, and the only error in there related to this issue is exactly what I’ve posted up there.

    As for corrupted files…it could have only been corrupted in the transfer…maybe if I try form the cPanel…



    …well, that did it. Man, was that ever fun. I had to delete the wp-admin and the wp-includes folders, and then log into the hosting control panel and upload the files through there (a whole 12 files at a time…so much fun.)

    Apparently, uploading the files via FTP *was* corrupting something. When I did it through the hosting panel, it worked just fine. Took a hlel of a long time, but it worked.

    Thanks for the suggestion, maerk!



    Yeah, FTP can be problematic. I’m glad you got it sorted though!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘current_user_can() error upon installation attempt’ is closed to new replies.