[resolved] "Current Widgets" list is blank (6 posts)

  1. peeds
    Posted 8 years ago #


    I installed WP 2.5.1 a few weeks ago and have tried a few different themes, without any problem.

    But suddenly, as I was trying a new theme, something went wrong with the Design->Widgets page. I don't see any of the widgets being used in the "Current Widgets" list, nor can I add any new widgets.

    This is the same with all the themes that I have tried so far at this point (even with the default theme and others that worked flawlessly before).

    It appears like something to do with "dynamic sidebars" has gotten corrupted. I am looking for any pointers that will help me debug this. If I had to restore some WP files to fix this, which ones should I start with?


  2. iridiax
    Posted 8 years ago #

    Beware: Not every theme supports widgets. Maybe one of these non-widget-ready themes corrupted something? I once had to reinstall WordPress after trying a plugin that required widgets on a non-widget theme. Hopefully you won't have to do this.

  3. peeds
    Posted 8 years ago #

    Most likely that's what happened. I am considering reinstalling WordPress. If I just rename the WordPress directory and replace with a new one and install WordPress again with the same config and on the same database, will it safely retain all the existing data?

  4. iridiax
    Posted 8 years ago #

    To reinstall WordPress, just follow the detailed upgrade instructions (even though you're really just "upgrading" to the exact same version of WordPress).


  5. peeds
    Posted 8 years ago #

    I tried doing that and I get the message:
    "No Upgrade Required
    Your WordPress database is already up-to-date!"

    Then, I tried this:
    1. Moved my blog to another directory.
    2. Created a new blog directory and copied WP files afresh.
    3. Made the wp-config.php point to a new database.
    4. Ran wp-admin/install.php, and it ran successfully.

    Now, I edited wp-config.php to point to my old database. With that, I can see everything in the blog as before. But the widget issue remains!!!

    Then I looked at the database tables. I have a feeling that the something in the database related to the widgets is messed up and that is why even with a new installation and old database, I am seeing the same problem (even with the default theme).

    Is there a way to delete or correct widget related entries in the database table? I think this is the fix I need.

    An alternative might be to start with a new database, and import only the posts, pages, users, etc from the old database.

  6. peeds
    Posted 8 years ago #

    It turns out that the theme I was trying claimed to be widget-ready, but with WP2.5.1, it has some issues. Tried another theme, and now everything looks good.

Topic Closed

This topic has been closed to new replies.

About this Topic