WordPress.org

Support

Support » Plugins and Hacks » WPPizza » [Resolved] Currency symbol

[Resolved] Currency symbol

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author ollybach

    @ollybach

    Hi Jorge,

    re prices to the left:
    you could mess with the css and or templates if you want or wait a few days or so and i’ll have this integrated as an option into the plugin

    re decimals:
    good point. again, give me a few days and i’ll have that integrated

    Plugin Author ollybach

    @ollybach

    ok,

    version 1.3 now has the option to:
    a) move the main big currency symbol (left/right/none)
    b) show currency currency symbol directly next to prices (left/right/none)
    b) hide decimals
    (from within wppizza->layout)

    hope that helps somewhat but let me know if there’s anything that misbehaves…

    thanks

    Olly

    Hello,
    I am very grateful for the prompt response. My results;

    Decimal:
    inside the basket no longer appear more (This is correct), but in the menu are still there.

    Currency:
    Inside the basket symbol only appears side right from in the list of items and can not switch sides.
    please check url,

    http://www.caferuso.cl

    Again very grateful,

    Well,

    I managed to fix the problem with the currency inside the cart.

    Just I replace line 21 and for now is correct.

    //$cartContents.='<span class="wppizza-cart-item-price">'.wppizza_output_format_price($item['pricetotal'],$options['layout']['hide_decimals']).' '.$cart['currency'].'</span>';
    		$cartContents.='<span class="wppizza-cart-item-price">'.$cart['currency'].''.wppizza_output_format_price ($item['pricetotal'],$options['layout']['hide_decimals']).' </span>';

    Can you help me with the menu. plis

    Plugin Author ollybach

    @ollybach

    if you change the template (as you did above) make sure you copied it into your themes directory, otherwise it will get overwritten in the next update !!!

    re main menu:

    can you tell me the following please:
    a) which currency are you using : I assume CLP but am not sure
    b) what is your wp-config.php file saying in:

    define('WPLANG', '');

    (maybe es_ES ? dont know…
    c) can you enable debug in wp-config.php

    (so it says

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    }
    and let me know any errors you have in wp-content/debug.log ?

    thanks

    (send your debug log to dev[at]wp-pizza.com ..thanks)

    Hello Again,

    Well I send you my debug-log. and I’m responding your request:

    define(‘WPLANG’, ”); Es_ES and my currency is CLP $

    best regards,

    Plugin Author ollybach

    @ollybach

    got your debug. thanks
    your theme seems to use some kind of caching .
    could you – temporarily – switch over to twentytwelve and tell me if the problem is still there when using that theme?

    thanks

    Wow,

    You are amazing. the problems are with the cache I will try to disable, I don’t know where but the solution is here.

    thanks

    Plugin Author ollybach

    @ollybach

    ok.

    glad we know where the problem seems to be now…

    shout if there are any other questions

    happy to help if i can

    Plugin Author ollybach

    @ollybach

    btw – not 100% certain – but it appears your cache in your theme is somewhere here:

    wp-content/themes/ristorante/ait-cache/

    maybe that helps

    Plugin Author ollybach

    @ollybach

    marked as resolved

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Currency symbol’ is closed to new replies.
Skip to toolbar