WordPress.org

Ready to get started?Download WordPress

Forums

NetBlog
[resolved] CURLOPT_FOLLOWLOCATION open_basedir error + GUI + netblog 3? (6 posts)

  1. Kristof De Buysere
    Member
    Posted 1 year ago #

    Hello,

    1)
    I have this error text in the upper section of my admin screen (but the plugin seems normal for the rest):
    Warning: curl_setopt_array() [function.curl-setopt-array]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /XXXXXXXXXXXXXXXXX/wp-content/plugins/netblog/core/DataTransfer.php on line 25

    It turns out the safe_mode is turned on, so it probably has to do with open_basedir settings. I'm on shared hosting, so I will probably have to contact my hosting provider to lift restrictions in php.ini.

    My question is however: is this essential for the functionality of the plugin? Or can I just ignore that error, without contacting my hosting provider?

    2)
    If I click on "Links" in the menu, then I don't see the nice GUI like the one that I can see in the screenshots on your website, or like in in the screenshot tab of the netblog plugin page in the wordpress plugin repository. I only see the title "Netblog MEL - Manage External Links", the smiling faces, and the message: "You do not have any external links, yet. But this is no problem. Adding External Links Go to the Edit Post ..." (it's a fresh install, so no links yet).

    Is that normal?

    3)
    I very much like the idea and completeness of the plugin. I am a part-time academic, so it certainly has some value for me. I saw on your website that you are soliciting donations to work on netblog 3.0. I might be willing to make a small donation, but I was wondering if you know other people who want to make a small donation as well, to get this development started? It would be rather stupid looking if I would be the only one to click the paypal button.

    Did you consider using a crowdfunding platform by the way (i.e. Indiegogo)? It also offers some visibility, but it comes at a price: you pay a heavy commission.

    http://wordpress.org/extend/plugins/netblog/

  2. Viktor Leberecht
    Member
    Posted 1 year ago #

    I,m on a self hosted wordpress (everyting updated to current version) and get that same error as Kristof:
    curl_setopt_array() [function.curl-setopt-array]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /var/www/web1160/html/wordpress/wp-content/plugins/netblog/core/DataTransfer.php on line 25

    What to do?

    Kind regards, Viktor

  3. Benjamin Sommer
    Member
    Plugin Author

    Posted 1 year ago #

    This is known problem of PHP and safe_mode. With PHP 5.4, this configuration option will be removed as it introduced more errors than it solved.

    Consequently, this error message will automatically disappear as soon as you update your PHP to 5.4

    In the meantime, I suggest to disable safe_mode in your PHP configuration.

    Maybe I provide a temporary workaround in case you cannot disable safe_mode.

    Thanks.

  4. Viktor Leberecht
    Member
    Posted 1 year ago #

    Thanks for the message. My hosting service is on PHP 5.3 and i can not change that. They also say that safe_mode is disabled.

    So the workaround would be much appreciated.

    Kind regars, Viktor

  5. Viktor Leberecht
    Member
    Posted 1 year ago #

    Have to correct myself. I changed the php to 5.3 but for some reason the change did not seem to take effect (have to inquire with my hoster).

    Nonetheless, also under PHP 5.2 the safe_mode is off, so that should not be the problem?

  6. Benjamin Sommer
    Member
    Plugin Author

    Posted 1 year ago #

    This error either appeared with safe_mode being enabled or open_basedir being set. Version 2.15 addressed this issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags