Support » Fixing WordPress » Curl SSL3 error on Ubuntu 18.04

  • In site health i have two critical issues with REST API and loopback request.

    Error code: cURL error 35: error:1408F10B:SSL routines:ssl3_get_record:wrong version number (http_request_failed)
    My host os is Ubuntu 18.04, PHP7.4-curl module with OpenSSL 1.1.1g

    I have been unable to find a soultion to the problem and the hint i am getting from the error code is that WP is insisting on using the PHP-curl function with SSL3 encription.
    What i have been able to diagnose is that the newest OpenSSL doesnt support SSL2 and SSL3 just TLS. Since WP insists on SSL3 via the curl_setopt() function i guess there is no way for this error to be solved.

    Is it possible to set up WP to use TLS encryption for curl?

Viewing 1 replies (of 1 total)
  • Tyler

    (@tylerthedude)

    Hi there,

    Which version of PHP is your web server currently running? You may try changing to PHP version 7.3 and see if that resolves the error. Also, is the above error coming from a line in the WordPress Core directory or within a plugin?

    Regards,
    Tyler

Viewing 1 replies (of 1 total)
  • The topic ‘Curl SSL3 error on Ubuntu 18.04’ is closed to new replies.